Nuendo recording issues on Macs with M1 chips

Hi! We are experiencing a very strange issue with our recording sessions on both a Mac Mini M1 and a Mac Studio.

When we press record the GUI lags/stutters very much and there is a delay on about 1-2 seconds when we press the space bar to stop the recording again.
The issue appears very sporadically. It can be there for a whole day and sometimes only for a short session on one day.

We have tried with Nuendo 10.3.10 and Nuendo 12, both with Sillicon and Rosetta 2 and it is the same issue on all of the versions. :frowning:

The strange thing is that we are recording to a smb network volume and all of our other computers in our different studios, which is running on an Intel Based Mac, but with the exact same audio hardware setup, doesn’t encounter this issue.

We have tried everything ourselves - tweaking the Nuendo settings, and tried with a different network cable etc. but without any luck.
The problems disappear if we lower the screen resolution to the “next” highest resolution on both Macs. The Mac Studio is VERY powerful, so this shouldn’t be an issue at all.

We have tried on different screens too with HDMI-out->HDMI-in and USB-C->USB-C.

The issue is not there when the project is located locally on the Macs.
We have also tried to disconnect the Apollo Twin in the recording sessions on the server, but the problem was still there.

Have you heard about any similar issues and are you able to help us out?

I’m not a Mac Expert at all (I don’t even use them), but this sounds like a network problem with some external storage. Do you have any kind of network attached storage where you are saving the project usually?

If yes, what happens if you try to store any kind of data, outside of Nuendo? Does it behave slowly in some way?

maybe try and find out if apple has perhaps changed network protocols for apple silicon mac’s. This might explain the difference between the intel mac and and the m1…
Apple may have dumped smb for m1s for example.

1 Like

No, SMB is the standard protocol for most storage connections, beside NFS. If it is a network problem it is probably some configuration issue.

Ok, not dumped but a change has been made it seems.

A German site, so translate with google if necessary. but i seems like a new version could be an issue? I’m not a network expert or anything but have seen similar issues in the past.
Other advice is to check permissions on the disk.
Good luck

1 Like

Hi both of you!

No, it is not an SMB issue. We have several Intel Macs running on Mac OS 10.x where it is working just fine where the GUI doesn’t lag when pressing record.

As I also wrote in my topic, we just found out yesterday that when scaling down the graphics settings to not be native to the screen, the problem disappears. But the issue also only appears when recording to an SMB volume.

I hope that makes sense!

We have already tried connecting to the SMB share from the M1 Macs with SMB 2.1 instead of SMB 3.1.1. That didn’t help a bit. :slight_smile:

Kein Problem, ich kann Deutsch ganz gut lesen :slight_smile:

The problem described on that website is related to an issue within Fritz OS, the operating system of the Fritzbox Router. AVM is pretty late in support of the latest version of SMB security and that is the problem with MacOS.

To make it short, SMB has basically three releases today, SMBv1, v2 and v3. All of them contain a different level of security, where v1 is desupported and totally insecure these days. As far as I remember started Apple with MacOS 10.10 (or somewhere in that area) to use v3 as the standard, FritzOS supports only up to v2. The effect was, no connection for Mac computers anymore and AVM had to fix this in their Router system.

In regard to the problem of the post here, if the MacOS release is the same on the Intel and the M1 machine, they both use the same release and level of SMB protocol support. Assuming both machines connect to the same storage, then the M1 has issues, the Intel machine not, so something seems wrong in the M1 configuration.

Permissions is a good hint, in case both machines connect to the same storage. If the two machines use different accounts for the storage attach, it might cause access problems. But in this case the access is usually denied completely.


Hmm, that is weird. What effect does a graphics setting have on network connections. Anyway there is some configuration in the M1 that has a side effect on the storage.

As I said, I’m not a Mac expert, so I can’t speak to configurations like this. I know networks pretty well (I have to…), but this combination of a problem is strange to me.

Sorry, can’t help here.

Yeah! This is so weird!

Especially when it only happens on the M1 Macs :confused:

I just did a quick search for M1 and SMB issues, there seems to be some known issue related to the M1 Macs

Couldn’t find a solution so quickly, but may be that is a hint to get you going somehow.

Yeah. We have already been through all of these “error” pages. And that didn’t solve the problem either :smiley:

I’ve also opened a ticket at Steinberg support and they have sent our system information to the developers so that they can look into it.

I don’t know how the Nuendo framework and the SMB network connection is processed in Nuendo - but from what I can tell, something must be off in Nuendo. :slight_smile: