Nuendo Windows: odd window behaviors and interactions

[Note: the thread has been renamed, and will be used to post as many strange behaviors as I can find]

I hope this is another obvious thing I’ve missed and hopefully just a setting somewhere I don’t know about…

I like having my Nuendo window full screen and my Project window full screen within it. But some actions seem to undock the Project window, like going to the cross-fade editor by double clicking on a cross fade, or opening the marker editor, and I have to find and click on the Project page’s maximize button to put it back in place (which isn’t always visible!).

Is it possible to freeze this so it doesn’t happen? Locking the Workspace doesn’t make a difference. It seems to me that these small editors should always appear on top and be dismissed without affecting anything else.

Thanks!

(Updated to correct terminology!..)

What happens if you drag the project window to full screen, rather than maximising it?

DG

  1. No matter what happens , the main Nuendo window (the main “containing” window, so to speak) is still full screen.

  2. The Project window becomes un-docked on call up of, say, the marker editor (Control-click on “SHOW” in the transport) within the maximized Nuendo window.

  3. Once undocked, dragging the Project window any which way doesn’t re-dock it to the maximized Nuendo window. It just stays floating.

  4. The maximize window button must be clicked on the now floating Project window for it to re-dock to the main maximized Nuendo window.

But this doesn’t happen with everything. For example, if I Control-click “CLICK” in the Transport, the metronome options appear without un-docking the Project window. But if I Control-click “SHOW” next to “MARKER” to edit the marker list, then the Project Window undocks from the main window as described above. It also happens with the cross-fade editor when I double-click on a crossfade to open that editor.

BTW, I forgot to mention that this is on PC, Windows 7-64.

Thanks.

But this doesn’t happen with everything. For example, if I Control-click “CLICK” in the Transport, the metronome options appear without un-docking the Project window. But if I Control-click “SHOW” next to “MARKER” to edit the marker list, then the Project Window undocks from the main window as described above. It also happens with the cross-fade editor when I double-click on a crossfade to open that editor.

When you do this, does your marker window take focus? Could it be an “always on top” vs not which is different on the windows that break your window layout and ones that don’t?

OK, I checked, but in cubase since I don’t have nuendo anymore. So in Cubase If I maximize the project and app window and open the mixer without always on top selected, the project window comes out of full screen. When I change the mixer to “always on top” i can open and close it without it dropping the arrange window out of full screen. Unfortunately, there is no way to set the crossfade editor to always on top, so you have to adapt. You are going to have to drag your arrange window to be full screen without it being in full screen mode.

Thanks, Tom: you’re totally right in that the Marker Edit window wasn’t set to “Always on top” while the others were; by doing so, the Project windows no longer gets undocked by the main windows. One down!

And you’re also right that the Crossfade Editor simply doesn’t have the “Always on top” option. An oversight? I guess I’ll have to make a workspace just for working with crossfades.

I really appreciate you taking the time to check this out.

Steve

A quick update: opening “Devices > Show Panel” and selecting the different available options there revealed a number of them with the “Always on top” option defeated and those all caused the Project window to undock from the main when called up. So I went through the list and enabled “Always on top” for the ones that I could.

Some don’t have the option (like 9-pin synch) but don’t cause the un-docking.

Any ReWire option box causes the problem, but doesn’t have an “Always on top” option.

So right now, it’s down to the ReWire options and the Cross-fade editor. I feel this should be a global option in the preferences. How do I report this?

Digging around, I’ve discovered something else:
Some windows, like the Pool and the Tempo Track will open in full screen. If used in full screen and closed, the Project Window remains docked. But if they’re unhitched from full screen, the Project window gets un-docked again. I’m sure if I keep looking, I’ll probably find more stuff.

It seems to me that Nuendo’s window management is up for some cleanup and revision. At least this thread has solved some of these little annoyances. But sometimes it’s the little stuff that helps workflow. Another example of faulty windows management: on my 2560x1600 monitor, the workspace fits 2 full vertically extended Mixer lanes and the Control Room just perfectly with the Transport up top, but you can’t dock them and when you select one of the Mixer windows, any open plugin window disappears behind the selected Mixer despite the VST Plugin “Always on top” option in the preferences enabled, and the option clearly enabled on the plugin window itself.

I hope Steinberg can find a little time to clean this up. Again, should I report this as a bug? And how?

Back to work! :smiley:

this has been a gripe for windows Cubendo users for a long time, it doesn’t happen under OSX by the way.


MC

+1 for this cleanup. It’s really frustrating.

Thanks for chiming in, guys. Since I’m clearly not the only one this is an issue for, how do I notify Steinberg directly? What’s the procedure for declaring this a bug? It has a definite repro, but it’s not a show stopper. Thanks.

OK, so it seems I can’t get an answer about how to report this to Steinberg. I’ve decided to just continue reporting the issues I find in this thread and make it the singular most exhaustive report of window behavior anomalies in Windows Nuendo anywhere… I’m revising the title of this thread too…

New item: opening the Pool window in a window already populated with Mixer windows: the Pool window remains behind the mixer windows and cannot be raised. There is no “Always on top” option for the Pool window. And when one of the mixer windows is moved to reveal the Pool window, and the Pool window is closed, the Project window pops up from it’s minimized state in the workspace for no apparent good reason.

[it occurs to me at this point that user configurable windows hierarchy of “on-topness” might be the way to go…]

TBC…