Number of issues with 'Get HD Files' (Blank, out of order, etc)

I’ve been using VST Connect for a number of years now, and while it is a lot better now that it was a few years ago, it still seems to be plagued with some irritating issues that make or break using it in a professional setting.

Some issues I’m running into all the time is with the ‘Get HD files’ option. Two things sometimes happen - the replaced audio file sometimes appears blank, and there doesn’t seem to be a way to re-transfer the file again. I just have to resort to the local preview quality audio clip that was there before. I’ve seen in similar forum posts the best workaround is to get the performer to send the local files over separately and bring them into the project with the ‘Get Local HD Files’ option, but being able to download HD files throughout the session as we go makes this super handy and a massive time saver, so it would be really great if this issue could be ironed out in future updates.

Another issue with the ‘Get HD Files’ option - sometimes when downloading a batch of them in one go, sometimes they seem to replace unique events with duplicates of another take.

See this image for example:

If you’re wondering why the image is under construction, that was simply because it was downloaded in the middle of another take and the images don’t render in until recording stops.

But this seemed to happen a lot - different takes would replace the wrong file. For example in the image above, ‘Violin 2 Mic_02_(HD)’ should have been the first take, but instead it was replaced with ‘Violin 2 Mic_03 (HD)’, which also replaced its own original take. There doesn’t seem to be a particular formula to how this works; sometimes amongst 10 takes, a few of them will be replaced with the wrong HD file. The only way to remedy this is to open up the project pool window and manually search for the right HD file and drag it into the timeline. However, when I do this, the audio clip appears to be a different length from the original take - it’s always longer, and/or doesn’t appear to line up with the grid correctly. I have to turn off snapping and nudge it in line for it to be in time, again super frustrating.

Another peculiar thing that happens - if I had to manually find, then drag and drop the HD file from the project pool into the timeline, it seems that VST Connect thinks that this HD file needs to be transferred over again, or something. The number of ‘Available HD Files’ increases, and when I ‘Get HD Files’ again, this happens:

It’s like it re-downloads the already existing HD file, then replaces and renames the new one with another ‘(HD)’ tag, and then again sometimes places them out of order. Not really sure what’s going on here.

I’m not sure if this all is something that only happens when using lanes, but I have a feeling it might be, as in the past there were issues with VST Connect consolidating all HD clips onto one lane, but that seems to have been fixed at least. Has anyone else been experiencing any of these issues?

And just while on the topic of downloading the HD files - why is it always in stereo? I only record the single mono input of the performer, but the HD file is always stereo, and sometimes the audio is only in one channel, and other times it appears to be in both. Either way I made another post to troubleshoot the input/mixer setup issues i’m having here in this thread, as I wanted to keep this thread focussed on the HD files issue.

My current setup:

  • Cubase 11.0
  • VST Connect Pro 5.0.1.545
  • MacOS Catalina 10.15.7

Performer:

  • VST Connect Performer 5.0.1.545
  • Windows 10

I don’t have the issues you’re experiencing and I’m a heavy user of the product in a professional setting. It’s been absolute magic to have this tool during Covid for both production and session reviews.

A couple of things. I never record while downloading. We rely both on our and the users connection for a reliable sync. Downloading HD files while recording could result in issues.

You mention only getting stereo tracks. As you’re probably aware, the Pro version allows you to mutli track - up to 16 tracks. I do this a lot with drums. As long as you set the record enable button in VST Connect (lights up red) on the track you wish to record for a mono input, it’ll record that track in mono. If you don’t do this then effectively you’re recording the stereo input only. Typical for me would be a drum kit with 8 mics. Each mic on its own channel with the record function enabled (lights up red).

When I’m happy with a take, I then go to the recordings tab and delete any takes I don’t want, to keep things tidy and to ensure I download any thing I don’t need. Then back to the manager tab and import the HD files. Once complete they are imported into their own folder as separate mono tracks and in sync position.

I’ve run sessions that have lasted several hours with no issues whatsoever. Some of my clients had to decamp to their homes in the sticks during Covid where internet connections here in the UK can still under 1mb in some areas. I was still able to run the session successfully but downloading the HD files was not possible. In this scenario they sent me the files via wetransfer. This is an easy process as the files are contained in a folder in their ‘my documents’ mac or pc, with the folder named automatically as the name of the session you created. All I do once I’ve received them is to go to the manager tab and use the import local files button and again they are imported as mono files and in sync position. Hope this helps.

Hey, thanks for taking the time to provide this info!

So I guess the method I was doing before (by using a regular audio track and selecting the input manually to ‘Left’ or ‘Right’ under the VST Connect Inputs) was the wrong way to go about it? As far as I understand, we’re supposed to create a dedicated ‘Performer Track’ from the VST Connect menu, is this correct?

I tried following your method of setting the red record enable button to ‘On’ for the tracks I wanted to record as mono. In my case I only needed to do it with one channel as I’m only recording one input. I then recorded 4 takes onto one performer track.

So my project window looked like this:

However, either I set things up wrong, or something isn’t working right here. Because in my Manager and Recording tab in VST Connect, it seems to only have recorded the mono track for the first take, the rest have only the stereo recordings:

So when I use the ‘Get HD Files’ or ‘Get Local Files’ (I tested both), my project timeline looks like this:

It seems to add a new track for the HD mono file of the first take, but not the rest, but yet still replaces all takes with HD stereo files.

At first I thought this might have been an issue with doing multiple takes on one audio track using lanes, but I tested the whole process again, except this time creating 4 separate ‘Performer Tracks’ from the VST Connect menu. The exact same thing still happened.

Am I missing something here?

So I guess the method I was doing before (by using a regular audio track and selecting the input manually to ‘Left’ or ‘Right’ under the VST Connect Inputs) was the wrong way to go about it? As far as I understand, we’re supposed to create a dedicated ‘Performer Track’ from the VST Connect menu, is this correct?

I tried following your method of setting the red record enable button to ‘On’ for the tracks I wanted to record as mono. In my case I only needed to do it with one channel as I’m only recording one input. I then recorded 4 takes onto one performer track.

You don’t need to do this. The performer track is created automatically for you. You only need and can use one. Remember not to use monitoring on the performer as it’s all handled via VST Connect. The reason its in stereo is for monitoring purposes. I mentioned my recording drummers using multiple mics. In VST Connect, I can can pan those mics, think overheads and toms for a good stereo image for monitoring purposes. What’s recorded on the performer channel is designed for reference but in some cases its good enough (hi res mp3), depending on use. You don’t have to record the HD version of it by deselecting record enable. But it will always record the reference. This way you can listen back and select the best take to download the HD files for. It’s a very well thought out process.

However, either I set things up wrong, or something isn’t working right here. Because in my Manager and Recording tab in VST Connect, it seems to only have recorded the mono track for the first take, the rest have only the stereo recordings:

What I see in your project window and what’s in your HD Manager tab and recordings tab doesn’t tally. Did you delete any files?

So when I use the ‘Get HD Files’ or ‘Get Local Files’ (I tested both), my project timeline looks like this:

Apart from the missing elements the creation of the vst folder is correct.

It seems to add a new track for the HD mono file of the first take, but not the rest, but yet still replaces all takes with HD stereo files.

At first I thought this might have been an issue with doing multiple takes on one audio track using lanes, but I tested the whole process again, except this time creating 4 separate ‘Performer Tracks’ from the VST Connect menu. The exact same thing still happened.

Am I missing something here?

Please note that at this time if you’re using cycle record, it wont create lanes for you. As I understand it, they are looking to add this functionality for cycle recording in the not too distant future. For now, best to record, stop and record again for the time being.

As for the missing takes, I do not experience that issue. Can you confirm that both you and the performer are using the latest versions of both VST Connect and Performer?

You don’t need to do this. The performer track is created automatically for you. You only need and can use one. Remember not to use monitoring on the performer as it’s all handled via VST Connect.

Yep, I only used one performer track (the one it creates for you) the first time round. And just did multiple takes (which resulted in multiple lanes) onto the one track. I did not use cycle record, just simply stopped and started.

But it will always record the reference. This way you can listen back and select the best take to download the HD files for.

By this, do you mean so you can go through the takes in the project window and delete them, which would then automatically remove them from the VST Connect Manager/Recordings tab? Or do you have to go into the VST Connect window itself and manually delete the audio files?

What I see in your project window and what’s in your HD Manager tab and recordings tab doesn’t tally. Did you delete any files?

Nope, those screenshots were taken consecutively right after I finished recording the 4th and final take. I then checked the VST Connect Manager/Recordings tab, and that is what is displayed.
EDIT: If you’re referring to the recordings being different lengths in the first screenshot compared to all being the same in the second screenshot, they are in fact from different test attempts (separate projects), but both were carried out the exact same way and had the same results. I guess I just mixed the screenshots together.

What should it look like? I imagine every file should have a little ‘+’ drop down that shows the mono file(s) within it as well, like it has for the first one (Performer Rec_01.aif)?
It seems it only does this for the first take. Subsequent takes don’t seem to create the mono file. I tried this in multiple new projects and the same thing happened.

Can you confirm that both you and the performer are using the latest versions of both VST Connect and Performer?

Yes, both VST Connect Pro and VST Connect Performer are the latest version, 5.0.1.545.
Just to eliminate anything to do with the versions, both VST Connect and Performer were reinstalled on our machines prior to testing.

By this, do you mean so you can go through the takes in the project window and delete them, which would then automatically remove them from the VST Connect Manager/Recordings tab? Or do you have to go into the VST Connect window itself and manually delete the audio files?

If you delete the take from the performer track in the project window it will also remove it from the takes shown in the HD manager tab. The recordings are still there in the recordings tab, which is basically the recordings on the performers computer.

It seems it only does this for the first take. Subsequent takes don’t seem to create the mono file. I tried this in multiple new projects and the same thing happened.

You should get a separate recording for every take when pulled into the project.

As a note, as long as you’re happy with it, I’d suggest you change to using WAV files and not AIF files. Also, in project setup use 'Broadcast Wave File. The additional meta data included in that format may help.

If you delete the take from the performer track in the project window it will also remove it from the takes shown in the HD manager tab. The recordings are still there in the recordings tab, which is basically the recordings on the performers computer.

Gotcha. I was wondering what the differences were with these tabs.

You should get a separate recording for every take when pulled into the project.

Seems that it’s not acting the way it should :confused:

I’ll change to .wav files nonetheless.

Hopefully someone with some more insight might be able to chime into this thread.