Numbered bar region behaviour at system ends

I needed a numbered bar region with parenthesised counts on every fourth bar like (4), (8), (12), (16). The properties gave plenty of options: I chose count frequency to be 4, appearance with parentheses, no range to be shown, nothing in the first bar, yes please in the final bar but no count at the ends of systems.

So far so good. But in some layouts some of the counts coincided with system ends. I didn’t want any other count than every 4th to be shown, but I did want - obviously - those every 4th counts even if they happened to be at the end of their systems.

If I chose ‘no dot show’ [at ends of systems], I didn’t get any of those unwanted counts, but the wanted ones (at the end of a system) weren’t parenthesized as were all the others .

If I chose yes [show at ends of systems] with or withour parentheses, this was fulfilled as expected - including the counts I didn’t want to have.

I tried everything that I could and I also re-created this in a test score: every time I chose the option ‘do not show’ [at ends of systems] or didn’t check that option at all, the unwanted counts didn’t appear, but the wanted ones [at ends of systems] appeared without parentheses.

I made the parts looking the way I needed by unorthodoxly moving all unwanted, parenthesized counts at system ends out of sight in engrave, but this might be an uninvited behavior of Dorico, might it not?

If not, I’d be happy to learn how to achieve parenthesised count appearance even at system ends.

There is a prior post about the same weirdness (Bar number region weirdness (Sep/2022)), but it wasn’t really solved.


Yeah, there seems to be a setting missing to account for this. I don’t use these that way often, but I think I’ve just done what you did, and blast them off the page in Engrave once the layout is finalized. Feels kind of kludgy though, and this really should be able to be done with a setting.