Numbering repeated sections for ease of reading

I have a 2-bar phrase which gets repeated 4 times, and I want to number them. I followed the instructions for using the repeats popover, but nothing happened!

Please confirm that Layout Options > Players > Numbered Bar Regions is appropriately set for your current layout.

Hi Leo, I have Show bar count in numbered bar regions checked.

Perhaps you could attach your project here, or a cut-down section of it sufficient to show the problem, so we can advise further?

Sure. The relevant section is labellled tabla solo, now at bar 5.
Raag Jai Jaiwanti Taal Deepchandi copy.dorico (1.2 MB)

Is it even possible to have a 2-bar numbered region?

Jan, you’ve not actually created a numbered bar region: Dorico isn’t clever enough to automatically work out where such regions should go, but you can select the passage in which you want numbers to appear, then type Shift+R to open the repeats popover, and type numbars into the popover, then hit Return.

Let me just clarify in case I’ve missed something. In the file that I’ve uploaded, I’ve just tried the following -

  1. I select from bar 5 to 20 inclusive.
  2. I type Shift-R, The popover has a first time repeat bar symbol.
  3. I type in the word “numbers”
  4. Hit Return.
    That is what I tried before, and I’ve just tried it several times just now and nothing has happened.

A. You don’t have the Layout Option turned turned on:

B. The syntax really is numbars, with an a.

Try numbars (as in numbered-bars).
Daniel Spreadbury is Dorico’s chief of project, you’d better follow exactly what he writes, as he’s probably the best reliable source concerning Dorico (followed by Lillie Harris, responsible for the documentation, and Pianoleo, the best of us users :wink:)
Ninja’d by Leo :rofl:

1 Like

A menu option is also available if the popover method either isn’t working or you prefer using the mouse to input things.

Aah that’s it - I automatically read “numbers” Thanks.

Oh well it wasn’t a solution - still nothing happened. Let me look at what Lillie said.

@Lillie_Harris I think step 3 at this page needs an extra bit to ensure people read this popover string correctly. It is all too easy to assume it is an English word. Something like “(Note: not ‘numbers’ but numbars)”.

1 Like

Ok I followed the Write>Create Numbered Bar Region method and now the selected bars have a red circle at the beginning and end. What do I do next?

Change the layout option to show numbered bar regions in the layout, as Leo suggested earlier in the thread.

Ok - I’ve selected the Show Numbered Bar Regions option and I have numbers on each bar. The problem is that as I mentioned in the original post - it’s a two bar phrase which is repeated, so I really need the number every two bars. Is there a way of doing that other than manually entering text?

1 Like

How do you actually want it to look? I’m not really clear what the accepted way to best number a 2-bar phrase actually is. Are either of these what you are going for?

1 Like

Either of those would do. I’ll check out Lillie’s last point.