Numbering single bar rests

Where does one turn off numbering single bar rests? Why isn’t this option included in Notation Options/Rests or Engraving Options/Rests?

Also, one of my parts begins with a single bar rest and not only would I like to get rid of the number, but for some reason the bar rest is the width of the two filled bars after it and I’m wondering why Dorico is allotting so much space to this empty bar.

You cannot turn off the numbering of single-measure rests–yet. IIRC, Daniel said that was an oversight and will be corrected.

Thanks! Do you have any ideas about the disproportionate length of that first empty bar?

If you could attach the project (or a cut-down version of it that still exhibits the problem) here, I’d be very happy to take a look and see if I can figure it out for you.

Here’s what I mean by the length of the first bar rest. The score is fine (although it’s not a rest for all parts) but the clarinet part has a disproportionally long empty first bar.
score.tiff (58.4 KB)
part.tiff (47.3 KB)

I really would need to see the project itself to be able to diagnose the problem, rather than a picture of it.

I just discovered the setting responsible for the inordinate length of the first bar rest. If, under ‘Layout Options/Bar Rests and Multi-bar Rests’, I deselect ‘Show Multi-bar Rests’, the bar rest becomes a normal length (less than half it was before). Obviously, all the other multi-bar rests then disappear, making this solution useless. I’ve tried this in two files in which one of the voices begins with a single bar rest and in both cases Dorico stretches this bar way out of proportion. Is this a bug?

Here’s another example, this time as PNG. I don’t understand why Dorico spaces this way.
The first image is the beginning of the score.
The second image is the beginning of the cello part with multi-bar rests turned off. The spacing is as I would expect. Unfortunately there can no longer be multi-bar rests in the part.
The third image is the beginning of the cello part with multi-bar rests turned on. Not only would I rather not have the number above the rest, but the first bar is disproportionately long.
BTW, I set the dynamics to be aligned optically with the centre of the noteheads, IOW, as far to the left as Dorico’s default settings will allow but I still find the forte a bit too far to the right. Does anyone agree with this and, if so, does anyone know how to take care of this globally?
score.png
part wo mb rest.png
part w mb rest.png

This is a rather strange bug. I’m curious if anyone else has been bitten by it and if the Dorico team can reproduce it. If so, are there workarounds or is a fix planned for the coming update?

Before this post gets buried, I’m wondering if anyone on the Dorico team can reproduce this.

You’ll get more attention if you attach a file that illustrates the problem, as Daniel has asked twice here.

Here is one of the files which has a rest for some of the voices in the first bar. With multi-bar rests turned on you get a disproportionally long first bar in the clarinet part with the number above it, and if you turn them off, the first bar gets a normal length but the part no longer has the necessary multi-bar rests. This behaviour isn’t specific to this document.
Romanze test.dorico.zip (426 KB)

The good news is that this problem appears to be resolved in the 1.0.10 update, so hopefully you won’t be troubled by it again once the update is available (which will be very soon now).

I’m glad about the new option in 1.0.10 not to show the number on single bar rests. Unfortunately, the old problem of the first bar rest being disproportionally large is still present. One change in 1.0.10 is that if the first empty bar happens to have a fermata in it, the bar length is normal. So in the two documents I’ve mentioned in this thread, the problem in the Schubert Romanze is solved, as the first bar has a fermata in it. The other, the song Amour bénis, still has it. Just as an experiment, I turned on show multi bar rests in the cello part and the 1st bar became very long, changing the layout by forcing one of the bars in the first system down to the second. I then added a fermata to the first bar and its barline immediately sprang back to its previous position, pulling the bar back from the second system. Showing or hiding the number had no effect. This is a strange bug!

Can you please attach the project in which the problem still occurs, so we can take a closer look?

The project I attached above (Romanze test) demonstrates this problem. After loading it into Dorico, go to Layout options and select show multi bar rests for the clarinet part. If you then look at the clarinet part all seems fine. Then delete the fermata and see what happens.

OK, thanks. We’ll look into this and report back.

I’m having the same problem, by the way. In my part, the first bar is empty and huge, even though I’ve set “Engraving Options > Rests > Width for a single bar multi-bar rest” to 4, which number I chose only because it was the minimum width for multi-bar rests and so I’m assuming that’s a standard bar length. This setting indeed appears to have no effect even if I set it to an absurdly large number (I think it was 12 before I set it to anything myself.)

Putting a fermata in that first bar does fix the spacing, but…the bar rest has disappeared! And the fermata is not over the center of the bar, where the bar rest would be.

Hoping this is solvable. Thanks!

Please attach the project here, or email it to me, so I can ensure this problem is caused by the same issue and not by a different one. If you choose to email me, please include the details of where the problem can be found and a link to this thread, so that I can keep track of things. I get so much email that if you just send me a project and say “here’s the project with the problem I was telling you about,” I’m afraid I’ll have absolutely no idea which problem you’re talking about…