Numeric Keypad Sharps and Flats

Entering notes on my laptop, the +/= key makes a note sharp, the _/- makes it flat. That’s logical: + means go up and - means go down.

On the external keypad I bought, = means sharp (+ doesn’t). That’s fine, but I cannot find a key on the keypad for flat.

Any thoughts? Not a big deal, but I have been entering notes with my right hand on the mouse and my left hand on the keypad, so it is awkward not to have a flat key.

It should be the minus(-) key?

Makes sense but doesn’t work.

Try assigning it to Note Input > Set Accidental > Flat as an additional shortcut. It’s likely mapped differently to the hyphen key on the main keyboard.

Konrad, you are using the US keyboard layout, so it is actually
= for sharp and
- (minus/hyphen) for flat.
So, as expected, on your external the
= does work.
The - (minus) on the external does not seem to be mapped to the same key as on your main keyboard, which is strange…

1 Like

@k_b, Thanks, but I’m having a little trouble finding this.

  1. I don’t see it in Edit | Preferences | Key Commands | Note Input Options
  2. Write | Note Input is just an off/on toggle.
  3. I can’t find it in Library | Note Input Options
  4. In Preferences | Key Commands, hitting - on the Num pad gave me a message that the key was already in use. I tried / on the keypad which would be fine, but I didn’t see how to tell Dorico that means “flat.” Having - or / on the keypad for flat would be a huge time saver–and either one is fine.

Konrad, I just looked it up.
You’ll find them under
Preferences>Key Commands>Note Input>Set Accidental>Sharp
and
Preferences>Key Commands>Note Input>Set Accidental>Flat
You can “Add Key Command” which you will do by pressing f.e. the / on your external number keypad.
Here you go (this is on my iPad):

1 Like