NVMe drive too fast? Projects crashing on load.

I’m getting a sneaking suspicion that my NVMe drive is actually so fast that it is causing projects to fail to load, and to crash Cubase. Poof. Vanished…
It’s either that or my new 12-core machine isn’t threading correctly when projects open.

HOW I initiate the startup of a .cpr is directly correlated to how frequently these crashes happen. If Cubase is booted up and then I open a .cpr using the hub or the File/Open dialog, or even if I navigate to the .cpr on my hard disk and click on it, Cubase crashes near every time.

If Cubase is NOT open already, however, and I start up a .cpr by directly clicking on it in the finder, Cubase opens and so does the project. Something about it taking that EXTRA time to load everything more slowly creates success. This is clearly an error of bits of data conflicting with each other, out of order, or something. I may be way off base…

The feeling I have is like I’m throwing 10 balls at a juggler at once and expecting him to perform… rather than one ball in at a time.

I’m at a loss. This is a new system. The just started happening today after using VST Connect PRO for a while, and then turning that all off, rebooting, creating simple projects, and testing over and over… and I finally figured out that I could open these seemingly “corrupt” .cprs simply by initiating the file a different way.

Note: it’s not a preferences issue, i deleted prefs and tried a bunch of other troubleshooting.

Any ideas?

It’s not the drive - I’m running an NVMe drive.

What version of Cubase are you running?

Cubase 10.5.12
Mac Mojave 10.14.6
Mac Pro 2010 with upgraded CPU, hard disks (NVMe and SSD on PCI bus), RX580 graphics card, USB 3.0 card.

…BUT the same thing happens in Cubase 10.0.50.
…AND in 9.5.

Just this simple act causes the error:

  1. Start Cubase
  2. create a blank test project
  3. save project
  4. close project
  5. try to reopen project with Cubase still open
  6. Poof goes Cubase
  7. Now click directly on that blank project in the Finder
  8. Cubase and project open successfully

I’m on a 6 core Win10 machine running my Cubase program from the C drive 500G NVMe - but storing the Project on an SSD, no problems. Could you try storing your project on your SSD drive and see what happens? How big is your NVMe drive, BTW? Is it partitioned?

NVMe and SSD’s here. Never had a problem with either.

.

Could this be a resource sharing issue. Many NVMe slots conflict with SATA ports and you have to avoid using the SATA ports which are used by the NVMe drive, especially if you want fully NVMe performance, otherwise your NVMe drive will run at SATA speed, or it could perhaps cause a problem.

The motherboard manual will have all this info.

Thanks for the help. I actually did try that and I moved the project over to the SSD and got the same error. I didn’t do the reproduction steps exactly though, I just copied over an already saved project, but the error is still happened. But I’ll try the whole sequence again saving on SSD and trying to reopen. I’ll report back.

I can report that on my MacBook Pro 2012, with the same OS - a device I try to keep exactly the same as my troubled desktop Mac Pro (virtually identical), these crashing problems don’t happen. So it’s hardware specific, and appears to be Cubase specific as well.

I’d love a Steinberg tech to look at my crash reports. I have an email into a fellow. Still waiting to hear.

Thanks. well, both drives are on the PCI bus, using PCI cards to attach. No SATA happening, except for a backup drive attached in slot 1.

II’m also not accessing the SSD drive that’s on the PCI bus when starting these simple projects. Just the NVMe. Hmm…