Occasional "License check could not be Completed!" error

I heave all the latest updates, but now and than Cubase 12 get stuck on " Content License check"
And after a long time I get the message " License check could not be Completed! "
After “retry” its starting up without any problem - it happens about once a week. ?
What causes this please?


Do you have any content, which is not part of Cubase 12 license? If yes, is the content licensed by Soft-eLicenser or USB-eLicenser?

Hi Martin
Not sure what you mean by any content thats ‘not part of Cubase 12 license’ ?
I have a lot of other 'stuff’on my pc other than Cubase 12 , but nothing active / not started up.
I still do have Cubase 11 on my pc, and the dongle( USB licenser ) that goes with it plugged in.
So the Usb licenser is still active along with some Soft- elicenser stuff that I don’t use anymore


Did you buy any other sound libraries from Steinberg? Do you use any 3rd party plug-ins (especially with iLok)? Is your iLok/PACE software up to date? Isn’t there any plug-in in the Trial Mode?

Only the stock Steinberg libraries that came with Cubase- I do have a lot Native instruments libraries All legal stuff and never a problem when using Cubase 11 - but when looking at the startup info, they all load very quickly. Its at the License check part that the problems begin.
As far as I know nothing with ilok/Pace and nothing on trail

I have had similar issues with getting stuck on “Checking Licenses”. I do have some Halion content that I am guessing is still under the old USB eLicenser, which I have plugged in. The problem occurs off and on with no pattern that I can detect. A bit frustrating as I just keep restarting Cubase and it has eventually gotten past that block.

I am running Cubase 12.0.30 on an iMac. I believe all latest system and Cubase updates are installed.

I think I solved it.
I have removed “Steinberg Lofi piano”. When starting Cubase 12 it turned out that this was the only vst that still falls under the elicenser/dongle. Booting is now much faster

I have a couple of Steinberg Halion vst instruments that are, like you, probably the cause. This problem is fairly intermittent. However a more common issue I have getting a message that I have unlicensed content, but Cubase continues running. I have posted this as a separate issue on the forum. I have recently moved the USB eLicenser to a different USB port. I had it on a USB port extender and is now directly connected to my iMac port. Have not seen the problem since, but since the problem was intermittent, I’ll wait on final judgement!

1 Like

Worked good for me for a wile, but suddenly the problems back?
it stalls at ; "cubase Version 12.0.40
initializing Content License check of 45contents "
after trying for 30 seconds or so. after that I get the message ;"License check for content could not be completed! Do you want to retry? " When hitting retry its there in a split second !
Its happening about two times a week. The dongle never whas a problem for me …

1 Like

This is now happening for me too. In exactly the same way.

Same has been happening here since all versions of 12, maybe once a week or so. Can’t even be bothered to investigate - not worth it any more.

I have the same problem with v12.0.50 : “content licence check of 58 contents” and i wait ! Why? Thanks


Do you have the latest update of the Steinberg Activation Manager and eLCC installed, please?

I’m having the same licence issue with Cubase 12…I restarted the computer then it worked but it happened again… it looks like it’ll continue interrupting…

This happens to me about once a week in Windows. What I found is that if I end the Steinberg License Manager process in TaskMgr, it (usually) sorts itself out.

Although one time, it de-activated all my ‘content’ which took me a while to figure out how to ‘re-activate’.