Octave lower playback issue when changing vst instrument

Hi, switching vst instruments/plug-in on the same staff/track from BBCSO Core Horn to NI Symphony Series Brass solo in Kontakt 6 the second one playback result in an octave lower than the previous one (C4 is played as c3). It’s not related to instruments, in Cubase all is ok. I know that a fix could be done in the expression map setup by the transposing option but I need to understand. Seems like something related to c3 vs c4 central C. So, where’s the issue? With Spitfire player is ok, with Kontakt the result is an octave lower (same track).
Thanks.

I suspect the issue is absolutely with the expression map. Check each of the switches in the expression map and keep an eye on the value in the Transpose field on the right-hand of the dialog.

I already did: all correctly set to 0, unless there is a global one instead of the single one related to every single articulation. I wanna try to make the expression map from scratch inside Dorico ( the one I’m using is imported from the Cubase one).

Well, if the expression map isn’t the issue, then we can only assume that one of the library developers has in their wisdom decided to shift the sounds by an octave, presumably in order to make them more playable on a MIDI keyboard?

I also already checked this in Cubase. No library transposition. All worked well in Cubase. Same version of Kontakt, same library.

That’s me foxed, then, I’m afraid. Perhaps some other forum members have these same two libraries and might have some further ideas.

maybe a c3 c4 middle c parameter must be set somewhere in Dorico?

Not that would affect playback, no. There are options for the display of octaves in note names on the General page of Preferences and specifically for expression maps in Library > Expression Maps, but they don’t cause notes to be played back at different octaves.

it doesn’t depends from a corrupted e.maps imported from Cubase. The same with the one I just created in Dorico. I just tried…

for now it’s easy to solve by transposing +12 in e.map…anyway if someone have a solution is welcome!