Odd and huge computer problem

I have an i7 2600 with 16gb of ram and it’s about 5 years old (babyface sound card). I use it for Cubase only and it’s been running great up until about a year ago. It then needed to be formatted badly so I did but instead of resetting things, trouble set in.

After installing Windows 7 some “redistributables” were missing. I had never had that problem before and had no luck fixing it. I then couldn’t install the LCC and Waves plugins because of the missing redistributables. Then I upgraded to 10 hoping it would fix the redistributables thing, and it did.

Then I installed Cubase and the real disaster set in: When I start a Cubase project everythings is fine but if I’m using e.g 3 instances of Revalver, two Zebras, Groove Agent and some plugins this horrible latency sets in. I’ve never had any problems with latency and the CPU is only at 12% and memory is at 26% at the most in this current project I’m working on. A year ago I was working on things that had much, much more going on without problems.

I ran the latency checker, and everything’s cool. 6 months ago the computer got a clean bill of health from a computer shop.

Is this a hardware failure? Because I waited too long to format or something? If so what could be the issue?

Or is it because of the faulty installation of Windows 7 that I guess, Windows 10 is now built on?

What would you do?


Any help will be greatly appreciated as I know next to nothing about computers.

Latency you say? As in a delay between hitting a key and hearing the sound?

yeah and really bad too. Completely impossible to record anything. But I’ve asked elsewhere too about this and people dont have an answer so I’m gonna have a computer guy look at it

And the delay isn’t there when you start a fresh project? That’s strange, latency should only really change with ASIO buffer size…
What’s that set to?

It’s strange all right!

It’s set to 1024, just as it’s always been

Well 1024 is too high for comfortable live input through an amp sim or vsti, even on the excellent RME drivers :confused:

But are you sure you haven’t added extra latency with a specific plugin? What happens if you click on constrain delay compensation??

I’ve been on 1024 for years and everything’s been fine, so that’s not the problem.

But, when I turn on the CDC, the latency goes away. What does that tell us? (I’ve never messed with that button)

That means at least one of the plugins you use needs more time than the 1024 allows for…
Question is which one, but that should be fairly easy to test, considering the fact that the difference is apparently quite big.
CDC basically disables delay compensation for plugins that cause too much latency. Check the VST plugins window, it’ll tell you:

When you enable constrain delay compensation it simply switches off plugs with any significant latency…so it tells us you have added a plugin or plugins that are adding the latency.

As suggested you can look in PIM (no list of latency like that screenshot sin latest versions - you have to select plug to show info in the bottom pane so not that easy) or just look in the project for plugs that have been turned off when you enabled CDC.
Don’t forget to check master out and control room too.

cool thanks. One thing though. Did they change the Plug in information tab in 8,5 which I’m on? There’s no VST plugin like on yours, so I can’t check which plugins are causing this

Yes…exactly as I said in my post.

thanks. (I didn’t see you post before posting the one above).

The odd thing is that CDC is working but it’s not turning off any plugins or VST’s. I suspected the H Reverb could have been the culprit but no, it’s on.

And, if I were to delete all plugins and VST’s the latency thing would remain, which I it wouldn’t if this was just a regular overload

Did you check control room inserts?

Ok, another update. Forgot to check the master channel before. It turns out that the L1 and Cubase’s Multiband comp get turned off by the CDC.

But, once I bypass them and don’t have CDC on the latency is still there.

This must be a computer problem of sorts, like the RAM or something. Thanks for the help people

No. The plugins are exactly what the problem is.

Bypass will not remove latency of a plugin as expected.

fuck, you’re right! Removing the L1 and the multiband did it! Thanks so much! Huge load of my mind.

I just don’t get why I haven’t had this problem many a times over the years whenever I used the multiband e.g on 1024?

In case you don’t realise you can choose whether to bypass or disable plugs.
Alt click the button in a rack will turn off or opening the gui and using the power button.

Multiband comp also has live mode which removes the look ahead.