Odd stem lengths won't correct

I have an odd problem with stem lengths giving strange behaviour, working in 3 voices.
The inner voice stem lengths cannot be corrected effectively in engrave mode - they just jump to a strange position.

In my attached example, I can circumvent the problem with double dotted notes, but I would like to move the beams on beat 2, the inner voice, to a more acceptable location.
Bar 1 is what Dorico gives with no attempts to change.
Bar 2 is what happens when I try to move the beam.
Bar 3 uses double dots and gives the sensible beam position.

Screenshot 2019-12-13 at 20.44.07.png
Odd beam-stem arrangement.dorico.zip (429 KB)

how terribly odd… jumps all over the place when you try to adjust with arrows and the alt key too. I’ve never seen this. XML import?

In Engrave mode select the lowest D in the second beat and in the properties panel check the voice column index, it will set (activate) the index to 0 and you will be able to move the beam of the inner voice as expected.

Thanks very much for that, Rafaelv - worked a treat. The beam moved into the correct place immediately.
Rather odd behaviour though - and I might never have thought of that.

Just one more oddity - when I add a slur to the lower of the 2 notes together, it jumps below the tie.
If there is no tie, it works fine.
And I have found out that if, in engrave mode, I check the ‘Disable auto curve adjustment’ box, it behaves perfectly.
I understand that this is used when using nested slurs - but I hadn’t known that ties would affect the issue.

Hi Andyforrest,

I don’t get the same result.
See the attached gif


Regards
Rafael

Edit. I’m sorry Andyforrest, my mistake, now I see what you mean, with a tie in the lowest note and not a slur.

Dorico cannot position “inner” slurs, i.e. those that are not on the outermost notes, automatically, at least for the time being. So disabling automatic collision avoidance for the slur is necessary in this instance.