Off screen window issue

Occasionally I get a window appearing offscreen in Dorico that I can’t find or close.

Running OSX Monterey, M1 macbook pro.

I have two screens and use multiple desktops on both, usually because I have way too many other programs going at the same time. But who knew I could run a big Digital Performer file and Dorico with BBC pro at the same time!

Today I’ve got Dorico open and it won’t play. I can tell that there is likely a window open but can’t figure out what window or where it is. Sometimes Dorico doesn’t like it when I open a menu item in full screen while my second screen is fullscreen on mail.

I think it might be a window in play/track selector. Possibly the endpoint menu. All I know is that in the Vst/Midi tab I can open up virtual instruments like spitfire bbc but in the track inspector tab the edit and gear menus are greyed out. I think it might be a Kontakt window that’s opened but quitting everything else doesn’t make it show up, its just somewhere slightly off screen. I’ve had this happen a couple of other times with menus off screen but been able to locate or close the window.

For now I’m figuring out whether I can export the flow, rebuild the playback setup or if one of the autosaves is close enough.

Has anyone else seen anything like this or have a solution?

In Dorico 4.3, we have made some changes that should prevent Dorico from opening a window outside of the current available display geometry. It would be worth making sure you’re up to date and running the most recent version.

You should be able to tell whether a dialog is open because you won’t be able to interact with the main project window (and may even get the “bonk” alert sound when you click on it). If the application itself is in focus, then hitting Esc should close any modal window that is preventing you from interacting with the project window.

This is Dorico 4.3.

I turned off system error messages a decade or two ago. Nothing worse than being hooked up to a massive sound system and here ‘bonk’ super loud.

I tried every combo of window closing keystrokes. Esc, command w, tabbing through, return. Couldn’t get it closed.

So I ended up going with an autosave. Once Dorico decides to open a window on a non-existent screen or just past the edge it keeps doing it every time you try to open a window. So from my end its better just to go back to an autosave. And since its black friday I might by a vertical screen as well, giving me just that many more chances of doing it accidentally.

By the way, Daniel. I do so appreciate you answering a weird little issue like this within 5 minutes.
Almost as much as I love writing orch cues for shows directly in Dorico and exporting them for direct use.

Another thing I guess you could try is to invoke Exposé and see whether you can spot any extra windows that way?

Tried that, from all windows.

I think sometimes it opens a window where the top toolbar is just barely on the bottom edge. If its the window of an instance of a plugin, then there are no key commands to close it. You have to hit the top left close button.

It happened again to me.
I’m wondering if the issue is related to saving Dorico with a plugin window open on another screen.

I reimported the flows into a new template and it worked fine. Just now I tried to open the project and the audio power button was off, turned it on and I can get sound out of the instruments but the playback button is greyed out. In the play menu under the VST and midi tab I can open plugins, but when I switch over to the track inspector the plugin window is greyed out. So something his happening in the track inspector but I can’t find it or figure it out.

It looks as if Dorico doesn’t (yet?) think the project has been completely activated for playback. Depending on the size of your playback template, this may take some time. The various disabled controls should become enabled immediately once the saved state of the plug-ins has been successfully resotred.

There might be some plugin that’s not opening, but its doesn’t seem to still be loading. Dorico has been open for a while. Activity monitor says VST engine is 28 Gb, though I do have DP also open with 25 Gb and activity monitor says I also have 10 Gb free. Unless its some conflict between DP and Dorico using some of the same samples on the same external drive.

I hope you’re not going to tell me I can’t keep working in DP, Dorico, mail, safari, chrome, pages, numbers, music, photos, messages, activity monitor, final cut pro and… all at the same time or something. Its an M1 max, after all…

No, I’m not going to tell you that. But for whatever reason, Dorico is not being informed that the audio engine data has finished loading, so playback is not becoming re-enabled. Troubleshooting that with a playback template that occupies 30GB RAM is, I’m afraid, beyond my capabilities.

Thanks, Daniel. That’s useful information.

I’ll try a couple of tests to see if it runs better without DP going anyways. Typically I push computers as hard as I can, but maybe I’ll back off and see if it does better without a DAW looking at the same plugin and sample locations.

Its been a while since I’ve had to troubleshoot, these systems are generally so good and the software so much more solid since my scsi soundtools, OS 7 days.

I find it’s risky for me to try to do anything before the playback ‘power’ button highlights when opening a file. On this 2018 MacBook Pro I usually have to wait several seconds. Dorico will allow me to do things such as show/hide panels and scroll while it’s still loading sounds, but sometimes if I am too eager to start editing things won’t work.

Thanks, Mark!

I think that was really the issue all along. Pressing the playback power button instead of waiting for it to go green all by itself!

When I closed the file and reloaded it and waited for it to load by itself it worked fine.

thanks, I’ll consider this one fixed.

1 Like