Official 3rd Party Plugin Issue Thread

Win 10.
VST3 version of Limitless 1.05
However, I found a workaround! Cannot believe I hadn’t tried this before. The problem in WL is obviously a GUI redrawing issue (or whatever it’s called):
Press the DMGaudio logo to see version number and setup. Voila - the GUI redraws correctly when closing that popup window.
So from being a major problem, this is now just a matter of two mouse clicks. Can live with that.

Still problems with DMG Essence on OS X 10.10.5

When loading the effect from master section preset it shows only the lower half of Essence, so there is no way i know of how to go to the upper half and be able to control the GUI.
That means i can not recall a setting, setting is basically lost.

Is there a way to start to use standard handling of plugin GUIs in WL in the future?
WL is the only program which does not seem to use a standard, which all other DAWs seem to use?

Thanks

First off … try the VST 2 version. DMG have had issues with VST 3 for some time now.

Also, if the issue still persists, try moving the plugin GUI slightly, this usually causes the GUI to redraw … it might display the setup menue (I’m on PC mostly) where you can hit exit and it will display correctly … or hit the DMG logo at the top.

Good luck.

Thanks for your suggestions, Rat.
I´m using the VST2 version, and no redrawing if i move the GUI.
Same thing with VST3 i just checked.
Stuck.

Somehow I can’t reproduce this here on OS X but I never use the master section or have to save/load master section presets. For a workaround, does it work if you fold and unfold the plugin GUI? This often clears up GUI issues. Do you get the issue if you load a new instance?

I would write to Dave @ DMG, he’s usually very responsive.

Here is a GIF of two things to try. The second option in the GIF is what I mean about folding and unfolding the entire GUI window:

Hi Justin,

yes it’s kinda weird. As said, new Instances load normally, it happens only when recalling saved master section chains.
I tried all the options, also folding/unfolding the GUI.
I had the same issues with Limitless in WL 9.0.35, but they seem to be solved now.
With Essence the bug seems to persist.
And yes, i wrote Dave already before posting here and before WL9.1 was released.

In the meantime i mastered a few albums in Reaper because i simply lost to much time with WL and it actually feels quite good.
I wasn’t happy with saving master section presets into a montage anyways, it feels a bit awkward if there is no folder where i can access the preset.
I used and liked the master section for working on a track and A/B-ing, and recording.

thanks!

I agree, I was very happy when the montage master section was added. I never cared for the global master section approach. I’ve made a workflow that allows me to never use it. I do any SRC using a 3rd party app and then do “Custom Montage Copy” to recreate the montage at new sample rates. Basically, all my processing besides dither is done at 96k and a 3rd party app does the resampling. Because I don’t need the Resampler, I don’t need the global master section.

I also do the analog gear portion of the mastering in REAPER but I do move over to WaveLab to finish the job, or for 100% “in the box” projects.

Hopefully it gets sorted.

Has anyone had trouble getting Equilibrium
To Pass audio?
Thanks in advance.
Jason

Hi … on a PC, no. It’s always passed audio. I’ve used this since the first week it came out basically.

Hi Jason,
zero issues with Equilibrium on macOS Sierra, WL9.5.2
K

Thanks
Dmg confirmed my incorrect instal.
Best Regards
Jason

AMBEO VST2 crashes just after loading with a message I’ve never seen from a plugin crash before. It runs ok in Wavelab from within Blue Cat Patchwork though.

AMBEO VST3 seems to be fine running normally in Wavelab.

WL 9.5.40

I get the same thing with Sonnox Dynamics VST3 in Wavelab. You can push buttons and turn knobs but they do nothing, and there is no metering. But it seems to work fine if you run it from within Blue Cat Patchwork in Wavelab.

That’s 3 plugins I’ve tried that seem to work fine from within Blue Cat Patchwork in Wavelab that, when run normally in Wavelab, have serious problems. (Acustica crashes on master section render, AMBEO VST2 crashes on load, Sonnox VST3 does no processing):

Acustica Ivory3 Comp 3B
AMBEO VST2
Sonnox Dynamics VST3

I guess it makes sense it would be different, but it would be nice if they worked normally in Wavelab, without Patchwork.

WL 9.5.40 Windows 10

Which version of Sonnox Dynamics VST3? In the Master section or in montage clip effects? I see no issues with this plugin here.

Hi Stingray. It’s version 3.00.0 May 11 2017, latest version I believe. It’s the same in the Master Section or Montage, doesn’t work. It’d be interesting if it works for you though. The VST2 is ok as liph said, but not the VST3, except within Patchwork in Wavelab, where it works ok.

Hi all, really sorry to see that you’re suffering from this VST3 problem with our Oxford Dynamics! I hope you’re OK using VST2 for now?

We fixed the VST3 bug some time ago, and it’ll be included in our iLok Cloud release early next year. stingray is on our beta team, so has some unreleased builds :wink:

Thanks sonnox and stingray. Good to know.

And I get the same result with these plugins in DDMF Metaplugin, which is similar to Patchwork. In Wavelab, Metaplugin and Patchwork make these problem plugins work ok. Which I guess makes sense because they’re different plugin hosts than Wavelab, probably more similar to how Cubase sees the plugins, but I’m just guessing. But I would imagine that many of the problem plugins in this thread probably run fine within Metaplugin and Patchwork in Wavelab.

But it’s also interesting and a good sign that Acustica and Sonnox both have or will have fixes on their end for the issues with their plugins in Wavelab.

Seen a couple of references to this one:
At this insertion point, the plug-in cannot accept the number of input channels
but no solutions.
I’m getting it with Waves JJP-vocals Mono/Stereo, CLA-vocals Mono/Stereo… in fact, several Waves plugins at random, when Mono/Stereo selected; seems that if I select the exclusively stereo option, this does not occur

I don’t use Waves very often in WaveLab anymore. The last issue I remember which I believe is resolved was the disappearing cursor.

I think it is time to get this plug-in problem solved once and for all. This has been going on way too long. WL should work with a majority of plug-ins not just those from the three suppliers you mentioned.