offset on recording

When I record on an instrument track the recorded MIDI events show with a large offset on the track (like 4 bars or so).
I must have changed a setting at some point but I can’t seem to be able to find the fix

Hi and welcome,

What MIDI Connection do you use? What Audio Device?

Please read some articles about WDM vs Microsoft MIDI drivers.