Offset Timecode

I can’t seem to figure out why my “empty” session defaults to starting the timecode at “” . When I import my video file I try to “set timecode at curser” but it chooses it’s own random number and won’t match to my video.

I’ve looked up youtube videos to try to solve this but nothing I try seems to sync up my video with the timecode.

Can anyone suggest something?


Double-check the Project Settings (Shiftiest + S) Project Start Time and Display Time Offset values, please.