Oh no, Dorico 3 won't even open....

I am on MacOS 10.13.6. I have been slowly moving from Finale to Dorico. Gotten fluent and was holding on to Finale because of things like guitar TAB. Well, I upgraded to Dorico 3 today. Installed and updated elicenser.

It won’t start up. Gets stuck with “eLicenser Control - Error, failed to send GetInfo command”. Can’t get past it despite updating eLicenser.

I have this problem with Dorico 2 regularly and it’s the only thing I hate. I hate this damn protection scheme because it doesn’t easily allow me to use Dorico on two computers. I go to the office with the laptop only to discover I forgot the damn USB stick. Finale may be flawed in many ways but it lets me work on two machines without moving some piece of plastic back and forth. As fate would have it my Cubase license is on the stick also and while recording on one computer it would actually often be good to be able to have music open in Dorico on my second computer.

But at least Dorico 2 worked most of the time. Now Dorico 3 will not. In trying for a few hours with restarting, moving the USB to different ports, etc, it will not get past the error dialog. At the very same time I can start up Dorico 1, 2 & Cubase just fine.

If there a fix for this? Or can I ask for a refund?

Thanks

I’m using MacOS 10.14.6 and have no issues with Dorico 3 so far, maybe you should upgrade your OS

HI Peter,

Can you open the e-licenser control program? If not, the problem may lie there.

I’ve got an issue at the moment with e-licenser when Dorico won’t shut down properly. The knock on effect is that linked programs are affected. I’ve found that restarting OSX clears it.

Good suggestion from David Tee, stop any program that is using eLicenses and open the eLicenser Control Center.
Does that start gracefully? If so, let the maintenance task run. After that, what licenses are shown, also the Dorico 3 license.

If the eLicenser Control Center does not start, try reinstalling it. The latest version can be also downloaded here:
https://www.steinberg.net/en/company/technologies/elicenser.html

Be sure to run the eLicense Control Center as Administrator (at least on a Windows machine).

Also, when I need to read music from one computer while working on another, I have found making a PDF for reference on one machine a less expensive substitute for buying a second license.

My iMac is a 2011 - 10.13 is as high as it will go.

I did all eLicenser updating and restarting. Just weird that I can run Cubase, Dorico 1 and most of the time Dorico 2. Over the years I have never had a problem with the USB stick (other than I still hate to deal with it).

I started shifting stuff around on the USB ports. While I don’t like to have my main external hard drive on a USB hub together with the eLicenser stick, that combo works.

So, yeah, I am curious now what’s new in Dorico 3. But, darn, I still wish I could easily use it on my laptop.

Thanks,

Peter

Back to square one. Dorico 3 won’t start because of eLicenser problem. Looks like it’s not the USB port. I have no time to trouble shoot that. Dorico 2 starts fine. Seems it’s time to ask for a refund.

I’ll send you a trial activation code that you can try adding to your Soft-eLicenser so that you can avoid using the USB-eLicenser, and see if that helps get Dorico up and running (you can then disconnect your USB-eLicenser).

Interested to see if this works …

Another update:
After moving my USB stick with the license around the available ports it ended up working on the same port with the external hard drive. Every once in a while Dorico 3 still refuses to launch. So far it has worked if I unplug the USB stick and after a few seconds plug it back in. Still sucks if I have Cubase running and need to quit out and then relaunch.

One peculiar thing, though, happens all the time:
When I click on “Dorico Help” from the “Help Menu” the eLicenser error dialog pops up. I can click OK out of it and the help page opens and Dorico keeps working normally.

i’m now getting this same error. MacBook Pro, (15 inch, 2014), 16 gigs of ram, core i7, OS 10.14.5

here’s a screen shot:


after this dialog is dismissed Dorico 3 seems to close but then i get another eLicense error and this is attached to an attempted launch of Dorico 3 LE:

quitting this dialog causes Dorico 3 (generic) to hang and it has to be force quit.

restarting the computer has no effect on this sequence of events.

forcing the VST engine to quit (why doesn’t this quit when Dorico either crashes or is forced to quit? isn’t this somewhat in-elegant?) allows me to perform eLicenser maintenance. the results look like this:


now Dorico 3 launches.

seems like a lot of effort for something that should be simple.

Those eLicenser message should not come in first place.
But unfortunately, because Cataline enforces only 64 bit applications, we also had to change the eLicenser to 64 bit.
The transition was not as smooth as we expected and we have more reports on eLicenser errors recently.
Our eLicenser team is working on it, but it’s not an easy task to solve.
You can try and plug-in your dongle to another USB port and see if that eases the situation.
Alternatively I can provide you a 32 bit eLicenser again, that should also run better,
but of course is no long term solution, because it won’t run on Catalina anymore.

I am glad to hear that I am not the only one having these golden moments. While I thought my Dorico 3 now mostly runs - sometimes with unplugging and replugging the USB stick it just decided that it won’t do that anymore. As always: Cubase 9, 9.5 & 10 and Dorico 1 come up without a problem but not Dorico 2 or 3. After half an hour of restarting my computer and unplugging and replugging the USB stick I give up in the middle of first big project for a customer on a deadline.

Sometimes it seems that just reading about this stuff gives you the same problem - like a virus.

Even more strange, that only Dorico 2 and 3 make trouble, that is very unexpected.
Do you want to try the 32 bit version of the eLicenser and see if that does better?

If the 32 bit licenser will still let me use my other Steinberg programs I’d be more than happy to try.

Yes, they will. I’ll prepare it and send you tomorrow a private mail with details.

today i’m having nothing but eLicenser errors trying to run Dorico 3 Pro (mac OS 10.14.5, MacBook Pro, 16GB, core i7). the funny thing is, after the eLicenser error, Dorico 3 Pro crashes out and then an instance of Dorico 3 LE tries to launch with a different eLicenser error! it too apparently crashes. i didn’t install Dorico 3 LE (i don’t even own it!). i guess i’m going to need the 32bit eLicenser as well.

this is VERY disappointing.


Fyi, I had the attached error message related to eLicenser. Per Ben Timm’s suggestion I ran the elicenser control software program (starting up as administrator) and updated everything, after which it disappeared.
Capture2.PNG.jpg

tried that. doesn’t work. this is a recurrent problem and today the problem has been recalcitrant. the last time it happened i was able to resolve it by restarting the computer, running the eLicenser maintenance and then Dorico 3 Pro ran fine… for about 2 days. according to Ulf, the 64bit eLicenser is having problems and he’s distributing a 32bit version to those who ask for it. i’ve asked for it. we’ll see if that ultimately solves the problem.

Hm … forgot to say that I am on Windows 7 and 10, on four different computers.

Hope you get this sorted out.

I’ve received several email messages in past days, from ia Native Instruments and Icon Pro advising to NOT upgrade to Catalina until it’s fully tested.

And then, yesterday, mac pros used by video editors using Avid all of a sudden couldn’t be rebooted. Total panic, and the tech people at Avid are woking hard to figure what’s causing the issue. If it even is an Avid issue, which I somehow doubt. https://variety.com/2019/digital/news/avid-mac-pro-corrupted-hollywood-1203347033/

Not to start another PC vs mac war, but I am negatively biased when it comes to Apple. Their focus is really not on professional audio / video, but iphones. That’s where the money is at. So every time a new OS version is released, there are issues with incompatibility. Apparently they do not work closely with professional audio developers (NI, Icon) to test operating systems before they are released.

Anyways, I hope you can get this sorted out asap.