Old "back up Project" bug rears its ugly head again [SOLVED!]

I started a new project in a temporary start folder like I do when I just want to check something.
Then I decided it worked good enough to save for the future so I used the “Back up Project” which worked fine in Cubase 9.5.
That includes moving everything including the folder for Audio files.
I assumed it workes in Cubase 10 as well so I proceeded with attempting to save an MP3 for reference.
Now the file path in the export dialog you can select to have the export land in the Project Audio Folder.
This used to work in Cubase 9 but in Cubase 10 it’s still pointing to my old start folder and I’ve done so hundreds of times.
The Export dialog and the Pool confirms that it’s the old path in both of them.

This took forever to fix a few version ago —
Say it ain’t so? :cry:

By the way, why can’t we have a dialog in the Pool to move the Áudio folder with its content to wherever we like, just because?
The only way to move the Audio folder now from within Cubase is to use the “Back up Project” command from the File Menu.
Or you can close everything and move stuff around manually and let Cubase complain and re-connect everything from with Cubase again …

I work exactly the way you do.
I have a “junk” folder called “Test” where unknown inspirations start.
If something starts to seem promising, backup project to a new folder.
So this alarmed me and I checked it.

It works fine here.
I can create the new folder anywhere, and it moves everything.

Unless I’m missing something you’re noticing.

Hugh

PS Someone had also claimed that “Files have been created . . . delete?” dialog when you don’t save a project had disappeared in 9.5.
Works in 10.

I used to do what you guys are doing too - starting projects in the same folder. This eventually got rather jumbled & confusing. So I started creating subfolders under my ‘sketches’ folder named after the date, e.g. 12-8-18.

Fortunately I’ve never been creative enough to need more than one folder a day.

But like Hugh the Backup Project works fine for me when these sketches graduate to become real Projects with a real name. Maybe there is a Preference involved (don’t think so, but…), or maybe the file/folder permissions in the OS?

I like this! :astonished:
It’s been a while since C10 was released so I kinda oughta have found this out before today on a second thought.
I know I started this project in a little … unorthodox way!
Maybe it was me who forced Cubase to spit it out again. :blush: :laughing:
I’ll try again …

I have a folder called “start” (of all things) which is what I point at in the !Steinberg Hub like:
Use default location [X:\start]
Then I set the project folder name to … “start”!
Cubase then just adds
start-01
start-02
start-03
They’re just empty folders and every once in a while there are a few files in them.
I really don’t use them and it’s a pretty foolproof way to start projects if you’re used to it.
If I want to save something I use “Back up Project” and every once in a while I purge the start folder.
It works for my mind and I don’t think I’ve ever lost a project of any importance, knock knock …
Then elsewhere I have one folder per song, neat and tidy!

Great minds think alike!

I do exactly this when I actually have an idea what I’m doing - rather than hunting.

Even call the overall folder “Sketches”. Project folder is “120818”.
Thought I was being original and clever . . .

I don’t use the “Default Location” thing. I just open a template and direct it to the “Test” folder.

Not sure if that makes any difference.

Hugh

no luck today.
I’ve tried with fresh preference folder, another user profile, restarted the computer, cleaned the bathroom and just anything I can think of.
Cubase does not behave like it used to do.
I also tried this on the last installation of Cubase 8.5 32 bit I have left on the computer-
Works fine.

The thing is that it seems Cubase 10 does everything BUT … updating the file path correctly is not done.
There is an Audio folder at the destination and there is a project file and there are some testa.wav files in the Audio folder plus some peak files in the Images folder.
It almost works.
But it’s night now …

Well there’s the difference. I use the dashes and you don’t! I feel the dashes always add a bit of extra spice to the tune.

Yes, this was in Cubase 9.5.30 https://www.steinberg.net/forums/viewtopic.php?f=250&t=138411&p=752156#p752156

About the back up Project function, unfortunately, it is an old story…

https://www.steinberg.net/forums/viewtopic.php?f=250&t=116518&p=637702#p637702
https://www.steinberg.net/forums/viewtopic.php?f=253&t=111089&p=608481#p608481
https://www.steinberg.net/forums/viewtopic.php?f=233&t=103359

In my case

  • if in the back up project option box I don’t select “keep current project active” all is working in Cubase 10
  • and in the export page, if I select ''file path>>use project audio folder", the folder is the right one (the audio folder created by the back up function)

HA! I can tell you without even looking I have the “keep current project active” option checked!
I never have that checked but I half subconsciously noticed it was checked but paid no attention … and this was very recently, like a few days ago, so …

So this is great news


Just checked … and I did like you wrote and NOW IT FREAKIN’ WOOOORKS!!! :astonished: :laughing: :smiley: :sunglasses: :sunglasses: :sunglasses:
It was kind of a showstopper because right now I need to do a lot of new projects as described above so this is a total relief!
Thank you very much!!!


and

When writing this update this I’m just back from running the installer and reinstalled Cubase with no change. :open_mouth:
But now all is back to normal so thank you again! :sunglasses:

Good!!!

But remember to check the projects created with the back up function.

If the “keep current project active” option was enabled:

  • the audio files are in the back up project(s) audio folder(s)
  • but the files in the audio pool (of the back up project) refer to the “original” audio folder where the files were created…if the destination hard disk was internal
  • there is no problem if the back up project was done to an external HD, in this case the audio files in the pool refer to the correct files in the back up audio folder

It works like I’m used to so right now my list of rules are short and simple:

  1. DON’T TOUCH ANYTHING!!!
    :mrgreen: