Omit Bar Rests in Cues not working

I selected the “Omit bar rests in cues” option in the Notation Options dialog, but I still see the bar rests in the piano part (cues are from Alto sax).

Does your project have multiple flows? If so, is it possible that you selected “Omit bar rests in cues” for a different flow from this one?

This has only one flow.

If you attach the project itself, we could take a look and see if we can figure out what’s going on.

Here you go!
I Love You.dorico (992.9 KB)

If I go View > Note and rest colors > Implicit rests, I can see that the rests there are black rather than grey - they’re explicit. See how the ones within the cue are grey?

Select the first rest at 39, then Ctrl/Cmd-Shift-A to Select More, then hit Delete or Backspace. Repeat for the next system.

Thanks so much! That worked, but I tried simply highlighting and deleting, albeit one at a time, and it didn’t work then. Is there some reason I need to select the “implicit rests” option to make this work?