Omnisphere, multiple out, and share

Example: I’m using omnisphere and i have made a multi preset loaded (8 parts with 8 outs).
I have loaded the plugin on part 1 and shared on part 2.
If i change something in part 1, it changes in part 2 either.
I want to mute, to change volume, and so on, for each part even in shared mode.
The only thing that i want to keep, is the sound and the samples.
Sharing make no sense for me if this feature is not available.

Not quite. The audio channel changes, but each Layer has its own MIDI controls.
If you use a multitimbral instance, you should be able to address the slots by MIDI channel, right?

It works for MIDI. The audio channel is common, but MIDI is individual per Layer. That is why a Layer swithes to MIDI controls when you select a shared Instrument there.
Btw. if you use your favourite Instrument almost everywhere, and you don’t want to use shared Instruments, it is a good idea to save a Layer template (menu Layer/Save default Layer). This template will be used whenever you create a new Layer.
Furthermore, if your Instrument has inidividual audio outputs, the upcoming version of VST Live (coming very soon) offers routing those channels to any Group, or Out channel in VST Live, then you can process each slot individually if MIDI doesn’t suffice.

Just looked it up:
“Omnisphere is 8-Part Multi-timbral. This means it has the ability to operate on more than one MIDI channel (up to a total of 8) at a time.”
So, use up to 8 Layers, each with its individual MIDI channel.

Thanks a lot, i will take a look this evening.
For live i’m using: halion 6, padshop, retrologue, pianoteq 8, omnisphere, a few roland, minimoog arturia and opx-pro from sonicprojects.

At least Halion is also multi-timbral capable.

song 1 part 1- halionsonic shared on midi 1 (GM063) - midivolume 60
song 1 part 2-halionsonic shared on midi 1 (GM063) - midivolume 75
song 1 part 3-halionsonic shared on midi 1 (GM063) - midivolume 90
volume is not changing in halionsonic when changing the part 1 to 3
transpose, zones, pitchbend are working
I want just to keep the same instrument and to adjust the midi volume
I can not load for every part the plugin again and again for the same sound. I have not enough ram for a complete setlist
I use about 60 plugins for a set (with share), I used Cantabile so far and there i use every plugin only once for a song.

Here, it does.

  • 3 Layers, each Instrument MIDI channel 1, 2, 3
  • Layer 2 and 3 to shared Part 1
  • change all 3 Layer MIDI (!) Volumes to different settings
  • Open Halion Sonic (SE) Mixer page and see 3 different volumes
    It is important that you set the Instrument MIDI Channel to where you want the Layer to go.

Thanks for your help.
It did not work for me, I did not understand the architecture of this routings.
Goog night

  • 3 Layers, each Instrument MIDI channel 1, 2, 3: I have only one instrument on channel 1
  • Layer 2 and 3 to shared Part 1
  • change all 3 Layer MIDI (!) Volumes to different settings
  • Open Halion Sonic (SE) Mixer page and see 3 different volumes
    It is important that you set the Instrument MIDI Channel to where you want the Layer to go.

We did find a bug that resets midi volume when you switch Parts. Pls. try again with the upcoming version (next week, we hope). Should you still have problems then, pls. feel free to report again.

Hello, has this feature already been implemented?
If so, are there instructions for this?
I want to use Halion and Kontakt with inidividual audio outputs.


Open the editor of HALion Sonic. There’s a “Activate Outputs” control on the left side in the header.

Click to it and you’ll see the Audio Outputs of the instrument

See you,

Thanks for the hint.
I tried this but I get no signal in the output.

Here is my testconfiguration:
2 Layers with a shared Halion.
Midi 1 => Layer 1
Midi 2 => Layer 2

In Halion I have 2 sounds.
Sound 1 => OUT 4
Sound 2 => OUT 5

I get the Midi-Signal for both an I see in Halion the signal for both sounds, but no signal in OUT 4 or 5. I tried with routing to Song Group. Also no signal.

What is wrong in my configuration.
Thanks a lot for helping me.
KInd regards Heiko

… it’s working fine here. Can you please create an example project and save it as an archive (“Menu / File / Save Archive…”). Zip the file destination folder and share it with us. Please make sure that you are running the latest version.


Here ist my example project (VST Live Pro (158.8 KB)

In this configuration I get not signal to OUT 4 and OUT 5.
Kind regards, Heiko

Thanks for the project, we can reproduce it and will check.

Hello @Heyo,

it’s fixed now. The next update will fix your problem and this example project. It was a special “HALion Sonic” / “HALion Sonic SE” / “Layer Template” problem. Sorry. But other instruments should already work with Multi-Out. Let us know if that’s not the case.

See you,

Hi, it works with the new version. Thanks!