one hanging note (C3) in my Cubase Artist 9

Can someone help me with a hanging midi note problem? I recently have been monkeying around with setting my Arturia KeyLab49 as the master midi controller and have put it as “Generic Remote”. I’ve had this keyboard for a while but I’ve only just now gotten this very specific problem. I have Cubase Artist 9 and running Windows 10. The C3 note ALWAYS hangs now. I can push the key in the virtual keyboard and make it go off, but this is seriously going to screw with my playing as I’m having to do this EVERY TIME! I used Midi Monitor and found that C3 is not getting a Note Off command. Instead, the aftertouch sends Note On" again and I get “Overlapping Pitch” (because I try to hit the note itself again to get it to go off) in the comment section. This is driving me batty!

I have been trying different VSTs and get the same result. It doesn’t seem to matter which VST and it seems to be just that one note C3 not getting a Note Off. I switched the input on the track I worked with from “All MIDI input” and to “Scarlett MIDI USB”. “KeyLab49” used to show up in the drop down but when using a MIDI cable instead of USB cord it has disappeared.

With further experimentation, I have noticed that this only happens when I’m using the USB to send MIDI. If I use the USB only for power (hooking it straight into a power strip with USB ports and not the computer, mind you) and using a traditional MIDI cable to go out from the KeyLab and into my Focusrite Scarlett 18i20, then everything works great. I would really like to fix this in the USB sending MIDI data, though.

Is there any way to completely reset the Generic Remote settings or otherwise edit this singular C3 note so that it sends a “Note Off” command? Should I somehow reinstall my existing Cubase Artist version? All my drivers are current and all of that.

Please help!


polarity setting for sustain pedal is configured properly. Many people have done is exported their MIDI project from Cubase and imported into Ableton Live . In fact the MIDI plays fine when people record arm a MIDI track and play it.

Greetings, I have similar problem with my Cubase Pro 9.5. Any note is hanging - not just C3 - on inputting MIDI using my midi keyboard. This issue does not occur on version 9.0.30 (or earlier) but only with update 9.5. I have uninstalled the upadte & reinstalled v. 9.0.30 & works midi data inputting works as expected. Now I have both versions installed & waiting for a fix, before I can use update 9.5 again.

Any help, in the meantime, will be greatly appreciated.

Many thanks