one MIDI - multiple OUT


i use superior drumer.
i have one MIDI track playing to the superior drummer.
the output of the superior drumer is multiple out (BD/ SD / HH etc)
i created an “instrument track” for that. i can edit the output of the BD but not the others because i can’t set multiple output for that instrument track. is there a way to do that without going to “instrument rack”


I don’t believe it’s possible, since you are using a single MIDI channel. A not-so-fun work around would be to separate your kit according to MIDI notes and assign them to a dedicated track with a different MIDI channel. The rest would be easy. You activate as many outputs as you need and assign them to the new MIDI tracks.

I haven’t tried this myself, but maybe you can assign a different output to each MIDI note number using the logical editor, although it’s a far-fetched idea, and even if it proves to work, it will take time.

I’d suggest you go the easy way and use the good old instrument rack!

Good luck.

Unless I´m misunderstanding you, you can of set multiple outputs for an Instrument track with 7.5. I´m doing that with SD also.
Separate audio output for every Kit piece of SD.

Had the same problem myself.
Press F11 and add the track that way this version gives options on the midi channels.

record the drum track on one midi track…dissolve it…put each resultant track on a diff midi channel 1-16

You don’t even have to dissolve the track if you just want to send them to different midi channels. You can use a drum map and set each note or groups of notes to a different MIDI channel.

That said, if you want multiple outputs, you have to use the Instrument Rack (F11) or the multi-out instrument tracks in C7.5

thx all for your answers.
sorry i realise my post was not very clear.

my problem was quite simple and stupid … my fault because i never use intrument track but instrument rack.
i could not display the multi AudioOut from superior drummer in the edit window like i was used to with the instrument rack (by setting the ouput under the instrument name in the inspector

now i found it you just have to “extend” the instrument track so you can display those tracks :blush:

thx again :wink: