"One or more components for Dorico Playback have not been found." [Resolved]

Hello

I use Dorico 2.1 on Surface 3.
I clean installed Windows 10 few weeks ago, as well as Dorico 2.1.
I did install “Dorico Playback 2 - Orchestra Library” as well as “Dorico 2.1 Playback 1 - HALIon Sonic SE 3”
I even reinstall the last 2 sound library several times (Dorico Playback 2 and 1).
I Restarted my computer, but I still get the notification error when I launch Dorico:
2018-09-07.png
What can I do (I can’t hear any playback sound).

Thank you for your time.

Can you follow Ulf’s standard advice, which is to create a new project with a piano instrument, add a few notes, then save it. Also do Help > Create Diagnostic Report. Attach both the project file and the zip created on your desktop to a reply here, and Ulf will no doubt take a look when he gets a chance.

Hello

Thank you very much for your help!
Here is the piano file I created:
https://1drv.ms/u/s!AmXvSWmFNi78h4dfpBX-rSeM3beEaQ

Here is the Diagnostic Report:
Dorico Diagnostics.zip (382 KB)
Just in case, I did a maintenance with the latest version of eLicenser (for an USB eLicenser), but nothing changed.
Dorico Diagnostics.zip (382 KB)

HSO is somehow not detected. Could you please stop Dorico and then delete the folder C:\Users<yourname>\AppData\Roaming\Steinberg\VSTAudioEngine2_64 ?
On next startup that folder and it’s content will get automatically recreated. Also a rescan of all soundfiles will take place which makes the startup process take a little longer than usual.
After that rescan, do you still get the message? If so, please create another diagnostic report and post here.

Ulf, in this context: I use Dorico Elements on my Laptop and Dorico Pro on my main computer. I do get these error messages about missing sound components on the laptop - as Dorico Elements uses HSSE (Elements) only. Is it in general problematic? Files I have started on the main computer with HSSE+HSO (Pro) I later open on the laptop and vice versa.
A solution could be to only use the HSSE (Elements) - also on the main computer - to avoid error messages in Dorico Elements. Or is there a more elegant solution?
Thank you for an answer.

No, there’s no problem. You can always use Play > Playback Template to reset a project to use a given template in any case, in either Elements or Pro.

Hello

Thank you very much for your help.
I did as you ask, but I still get the same error message.

After deleting the folder “VSTAudioEngine2_64”, and restarting the (computer to be sure and) Dorico, the file was recreated, but after scanning for sounds I got the same notification for missing playback files.

I then reinstalled “Dorico Playback 2 sound library” using Steinberg Download Assistant, but I still got the same message:


Somehow, Dorico detects HALIon Sonic SE instrument, as you can see in the picture above, but I don’t even know how to use them.

I created a second piano file that you can download here:
https://1drv.ms/u/s!AmXvSWmFNi78h4gAuybRzme6rw-Pug

as well as a Dorico diagnostics file:
Dorico Diagnostics 2.zip (614 KB)

Thanks for the data again. Still no sign of HSO. I need to take a closer look tomorrow and also maybe need to discuss with others. I’ll come back…

Hm, please do me a favour and open the HALion Library Manager (press the Windows key and type “HALion Library Manager” in and return). Go to the ‘Installed’ tab whichs shows all the installed libraries. What does it show there? Only the HALion Sonic contents? No “HALion Symphonic Orchestra”? This is how it looks with me:

Just chiming in to say that I also get this error occasionally with Dorico 2.1.0.1067 on OSX El Capitan (10.11.6). It seems very random; sometimes I get the error, sometimes not.

Eine oder mehrere Komponenten, die Dorico für die Wiedergabe benötigt, wurden nicht gefunden.

Bitte führen Sie den Steinberg Download Assistant aus und installieren Sie die Pakete:

  • Dorico Playback 1 - HALion Sonic SE
  • Dorico Playback 2 - Orchestra Library

The playback works properly, despite this message.

Hello
Sorry for my late reply.
Here is what I see in HALion Library Manager:



I have to say that I don’t have any problem with my other laptop (I’ll edit the last messages).
The problem is only with my Surface 3, the one I used for reporting the problem and doing the Diagnostic Reports.

Thanks for your time

Hello

I might have held an important information for resolving this issue: on the Surface 3 I use, I have only partial rights on my session (as a family member, the main owner of this device is my wife). On my laptop, where I have all rights, the sounds works just fine.

With that in mind, I updated the latest version of Dorico: 2.1.1 and ran Dorico on the administrator session of the Surface 3, and “voilà!”, no more error message.
Unfortunately, for whatever reason, I still can’t hear anything. (I checked, it’s not part of the “volume mixer” on Windows).
When Dorico isn’t running, the sound works just fine with other application (such as a Web browser for example).

I don’t know if that useful, but I did an other diagnostic report and a piano file, just in case.
Dorico Diagnostics 3.zip (354 KB)
https://1drv.ms/u/s!AmXvSWmFNi78h4ogX1McKGYSgwEyKQ

Thank you for all your time and help!

You don’t hear anything because Dorico can’t find any output ports to stream the audio to.
Please go to Edit > Device Setup and in that dialog press the Control Panel button, another window will open. At the top is an option about “allow exclusive access”, toggle that and see if in the list of outputs then ports appear.

Hello

I’m very sorry for not having told you about the session lower rights I was using…
I launch Dorico with administrator rights now and it works fine (no more error messages).

Thanks for the tip about the output ports.
I did as you said, but I don’t see any ports to stream the audio to…



Sorry for bothering you with that… Any help would be much welcome!

The first picture shows that you have one output port, namely “Speakers/Headphones (INTEL SST Audio De…” and that is all that is needed. So again, if you launch Dorico as admin, start a new piano project, does sound then come out of the Speakers/Headphones? If not, please again, create a diagnostic report and post here.

Hello

Thank you very much for your help!
Problem 100% solved.
Sorry for taking your time for this matter.
It’s so much better to be able to hear what I do!

All the best!

You’re welcome. Great to hear that you are up and running now.

I am also having this problem, having caused it try to solve another playback error. I attached a diagnostic report, but the site wouldn’t let me attach a .dorico file. Any help in getting up and running is greatly appreciated.
Dorico Diagnostics.zip (300 KB)

Welcome to the forum, DGMuu. I’m very sorry that you’re experiencing problems. Is the specific issue that Dorico is complaining that some playback components are missing? If so, the first thing to try is to reinstall “Dorico Playback 1” and “Dorico Playback 2” from Steinberg Download Assistant.

I have redownload and reinstalled both playback packs several times. The original problem was that it just wasn’t playing. That is resolved. Now I just can’t get Dorico to recognize that I have installed the second sound pack. Thanks!