Open meter issue

Hello, I often use open meter, and one of the first steps I have in my early draft is making a bunch of open meter measures, just because it helps me translate from my paper/pencil drafts.

Sometimes, when I enter in a note, this happens to the measures after it. Any ideas why? It goes back to normal when I enter a note into one of the truncated measures.

It’ll be because the last note, possibly on each staff, has the “Ends voice” property activated in the Properties panel. This tells Dorico to suppress all rests after that note, up until the next note in the voice. If there’s no subsequent note in the voice, no further rests will be shown, and without any rests, Dorico has nothing to use to calculate note spacing.

Ah! Do you happen to know if there is a way to prevent this from happening other than manually in engrave mode?

Be careful about removing rests? (the Starts voice and Ends voice properties are what get set when you use the Edit > Remove Rests command)

And if you don’t want to see bar rests in empty bars, use this option instead: