Option to turn off mouse scroll wheel changing mixer values!

It is one of the most infuriating “features” in Cubase. It makes the simple acts of navigation and control adjustments a minefield. I have screwed up settings countless times because of this functionality.

What I’d like is to leftclick/drag over a control or data entry point. All the scroll wheel should do is operate the selected window’s miniscule scrollbars. The exception to the rule would doubleclicking on a data entry field (or even a GUI control to make it “hot”) …then the scrollwheel can be used for data entry without changing any window navigation until Enter or Return is invoked.

+1

+1

I might propose something from a different angle:

A modifier key which allows “safe” mouse ball use while hovered anywhere over the mixer window. ie. no controls will respond to the scroll wheel/ball while the key is pressed. This way, you can enter values with the scroll ball AND have safe window scrolling too. :sunglasses:

* I can’t stand trying to turn knobs with a cursor, so I frequently use the mouse ball to enter values. BUT, I also use the mouse ball almost exclusively to navigate around my windows.

1 Like

+1.

It amazes me that the good people at Steinberg still haven’t done anything about this. So many users complain about this obvious design flaw. An option where one can activate the feature makes so much sense.

This is exactly what I was thinking and suggested in my above post, except the reverse - modifier key allows changing parameters via scrolling. It would be great to have the ability to have the option to change this in the preference menu.

+1
& good job on hunting those other threads, tadashibashi.
It goes back to 2015 & still not changed this critical flaw.
hope this thread gets enough attention this time to not be ignored anymore.
Peace

OMG! YES YES YES! i accidentally change SENDS and INSERTS ALL THE TIME! I’m sure its a MAC thing but PLEASE do something about this!!

+1’ing this one again, so it won’t disappear. Still pisses me off every time I scroll the mixer.

+1

+1

Yes

+1 Holy Cow this gets me into trouble.

+1

Please fix this!!!

+11111111

(PS: it’s a PC thing too)

Seconded. Now I have to move to the bottom scroll bar, or enable the mixer overview but dragging in that is glitched.

+1.

+11111111111

+1

Oh god - so want this.! +1

The workflow is so disappointing in the MixConsole; all that effort in the design/implementation - and I don’t think anybody uses it (Channel Strip particularly). Not just because we all have better tools; its so clunky and frustrating to actually use and get up to speed with…

No. Fun.