OS X 32-bit: Panic Warning and low memory

I have an iMac 3.4 Ghz i7 system with 20 GB RAM. Am running Cubase 7.01. My audio interface is Mackie Onyx 1620. I am using Native Instruments and I keep getting warnings from Cubase that I am low on memory, and even a “Panic” warning that if I continue doing what I’m doing I am very likely to experience a crash. I checked my activity monitor, and I had 7 GB RAM Free! Yet Cubase still crashed.

I have both ASIO-Guard and Multi Processing activated and am running at a full 11.6 ms Latency!! (5.9 Input, and 5.9 output), and am recording in 24 bit 44.1khz.

Can anyone suggest ways for me to avoid this? If it helps, I will boost my RAM to 32GB, but somehow I don’t think that’s the problem.

Thank you,

Instead of mindlessly spending more money on memory you should just switch cubase to 64 bit. Open the file inspector on the app and deselect the 32 bit option.

Which native Instrument vsti?
Personally I have had issues with Kontakt, which is what I assume you are talking about.
I also assume you are running in 64 bit?
Check that you don’t have any 32 bit dll’s in the x86 folder - delete them. Do the same for all NI instruments.
It is possible you are loading a 32 bit version. Again an issue I have had.
I hope that helps!!

Perhaps a little clearer?

Thank you! Where exactly do I find this “file inspector”. Nothing of that name shows up on Cubase, and I don’t recognize a system setting by that name. Nor could I find an X86 folder.

Thank you,

X86 is for PC I believe. Make sure your mac is running in 64 bit see below:
If your Mac uses the 32-bit kernel by default, but supports the 64-bit kernel, you can start up using the 64-bit kernel by holding the 6 and 4 keys during startup.
If your Mac uses the 64-bit kernel by default, you can start up with the 32-bit kernel by holding the 3 and 2 keys during startup.
Your mac will revert back to default kernel upon reboot. Just google how to determine kernel of mac for instuction
To select the 64-bit kernel for the current startup disk, use the following command in Terminal:

sudo systemsetup -setkernelbootarchitecture x86_64

I think Cubase on MAC defaults to 32bit but if you google Start Cubase 64 on Mac. You can get instructions that will help you better than mean people that know everything here lol; Here is a link on steinberg site for operation in 64 bit.

I am not sure of your expertise in computer technology but 32bit programs only can use 3gb of memory address and this is why you are getting these messages. 64bit can use an infinite amount of address so you will be able to take advantage of the powerhouse machine you own

I am no longer using my macs but all computers work on that same premise. Windows is a little different in that it runs both 32 and 64 at same time. You may run into a few issue with certain plugins that you use but you will know soon enough
Hope this helps.

That’s perfectly clear imho. Note he’s on a mac, and not on windows like your answer assumes.

Open the applications folder with the finder, select the cubase app icon and press Command-I. The inspector pops up and allows you to change between 32 and 64 bit program launch. Alternatively you get the file inspector from the edit menu by selecting “information”. Try to remember this, it’s very fundamental to using a mac.

I’d recommend against any such procedure. First of all the memory available to an application does not depend on the kernel running in 32 or 64 bit, only the binary of the application determines the addressable memory range in the OSX memory model. Secondly, the 64 bit kernel takes up considerably more memory for all sorts of kernel tables, so it actually steals from your application memory. Lastly, there are still drivers and extensions that don’t work well or at all with the 64 bit kernel, partly because that kernel also changes some internals that are not related to the address bus size. The advantages of running a 64 bit kernels are rather slim and mostly come from shorter kernel function calling times from 64 bit apps. On the other hand a 64 bit kernel performs worse with 32 bit apps.

So to sum up I would rely on the decision Apple has made with your OS and hardware defaults whether to run your kernel in 32 or 64 bit mode. Unless you know exactly what you’re doing you should just leave it like that.

You guys all rock! Thank you and thank you again!

I was aware of the 4GB limitation on 32 bit systems but just assumed Cubase was running in 64. Hopefully the problems will disappear. If not, you’ll be hearing from me again :mrgreen:

Okay. Changed it to 64 bit (and held down 6 and 2 when booting the computer after I was still having issues).

First message I just got:

“WaveShell-VST is not compatible with current application” Wave Shell-VST and the Waves Plugins can only run in applications that support VST sill Plugins (kPlugCategShell).

So unfortunately, I do not have use of my Waves library in 64 bit.

Also, I’m still running into peaking issues. I’m not sure why: the entire sum of all the sample voices I’m using at any given time are less than 5 GB. As I play more and more keys however, I get closer and closer to 100% on the peak meter. I just got the following message from Cubase:

“BACKGROUND LOADING WARNING: Your memory is getting low. Please use the purge function to free some resources. Kontakt will progressively cache only the required samples for playback and offline bounce.”

This message even though I have 12GB of FREE RAM!

It just doesn’t seem right that this should be happening on a system like mine. I especially put in the extra $$$ souping up my Mac to avoid this. On Logic, I just completed a symphony using over 30 of Logic’s instruments - with absolutely no issues. On Cubase I run into issues after using 4 or 5. Of course NI VSTis are probably a hell of a lot more powerful than Logics, but still…

One idea that just popped into my head: I’m running my Kontakt samples off a separate internal drive (the library is 250 GB so no room on my SSD). Could that be the issue? For that matter I’m doing the same for Logic with no problems.

You need to post your specs if you want free tech help! Update your profile, use google to search out answers to these things you’ve posted. Eliminate the easy ones and post back on whats left. I have no idea what your processor-/iOS/memory type/Buffer size/Sound card etc is. Be prepared and update your Bio! When you say you are using NI and Waves say what version. I am not going to be able to offer much tech help because of time involved but if you are serious and don’t want to invest time in learning there are pros I can recommend that do this stuff for studios everywhere. Also go to steinberg.net and read about configuring your DAW
Good Luck, Kenny

Thank you. I did fill out my signature with all that info but for some reason it doesn’t show up - even though I have selected to show my signature at all times. I therefore did all I could to give you all the info you asked for in my first post at top. If you have any ideas of how to make my signature show I’d appreciate it a lot!

In regards to your signature, there are two sections in the Steinberg account area. One is your registration info and the other is your forum info. You need to update your forum signature.

I have updated my info + an Avatar, but I don’t think a new member can get the changes until they are a member. I went back to zero when I joined My Steinberg. I think I need to get to 100 posts. Or maybe I am totally wrong and have overlooked something - the great thing about this forum is that somebody will soon point that out.

Not sure about signature as I never had that issue, maybe a new problem. I did ask in last post, but again if you can post what your sound card is, the buffer size you’re using etc that will help. Lets just get to it wo fixing signature as you may need to start a new tread for that.

Did you switch cubase to start native in 64 bit? What version of waves are you using? I believe only waves 9 is 64 bit…sorry that’s the way it is so you will have to update as bridge doesn’t read waves .good luck with that, there is a work around for PC using shell to vst app, don’t believe there is for Mac though. Your Mac should be powerful enough to run the NI etc. post your versions of all these things here. Make it easy for us to try and help you please. Sometimes writing all down helps you think logically also, it is how I trouble shoot for myself. Again I no longer use Mac but a computer is a computer and I’m a nerd lol

I believe it is your setup…post sound card, buffer size, are you using new tools available Asio guard etc…I’m on phone so excuse typos please
Have a great holiday


The OP posted all the info about his system is the very first post he made, yet people yell at him that he should do so.

The sig change issue is known, see the Forum Issues forum.(I turned off my sig till this is fixed)

As far as chony’s problem… (sorry if this is redundant)

What you don’t need to do is change whatever OSX is running in be it 64 or 32, which is what you described as having done in your earlier post. (where you held down keys when you started up)

You need to get info on the Cubase app, and look at this:

Also, Are you running Kontakt’s memory server?

doh! because you’re using 32 bit!

I stated this in in two prior posts but PNG is definitely better way to go ,
Copied from Apple Site:
“If you are using OS X Mountain Lion, switching to a 32-bit kernel is not supported. Mountain Lion uses 64-bit mode.
OS X Lion and earlier versions of OS X support a 32-bit kernel. Switching to the 32-bit kernel allows you use products that use 32-bit kernel extensions.”

This is why setup is needed for accuracy.

More info via apple.com:
"Mac OS X v10.6 and later include a 64-bit kernel. On hardware that supports the 64-bit kernel, you can choose whether to start up (boot) your Mac using the 64-bit kernel or the earlier 32-bit kernel.

You can use either of these methods:

Method 1: Startup key combination (for current startup only)

If your Mac uses the 32-bit kernel by default, but supports the 64-bit kernel, you can start up using the 64-bit kernel by holding the 6 and 4 keys during startup.
If your Mac uses the 64-bit kernel by default, you can start up with the 32-bit kernel by holding the 3 and 2 keys during startup.

Your Mac will revert to the default kernel the next time you reboot it.

Method 2: On-disk setting (persistent)

To select the 64-bit kernel for the current startup disk, use the following command in Terminal:

sudo systemsetup -setkernelbootarchitecture x86_64

To select the 32-bit kernel for the current startup disk, use the following command in Terminal:

sudo systemsetup -setkernelbootarchitecture i386

Note: This setting is stored in the /Library/Preferences/SystemConfiguration/com.apple.Boot.plist file and will take effect every time you start up from this disk. If you start up from a different disk, the setting on that disk, or the hardware default, will take effect."

I am confused are you saying its possible for iOS to run Cubase 64bit programs while Operating system kernel boots in 32bit mode? Wasn’t aware that you could address more than 4gb of ram in any way running 32bit kernel, interested in how this works or why even run Cubase 64 in you are in 32bit iOS kernel.

If this is case I didn’t know, or I don’t understand this properly. TIA for explaining