OS X Big Sur UR22C audio driver doesn't work

Hello, everyone.
I have a problem during last OS X update.
My current setup:
Screenshot 2021-05-24 at 18.32.41
I’m using UR22C to record vocal.
I have installed new driver Yamaha Steinberg USB Driver 3.0.5 from Steinberg official site and it seems like this driver doesn’t work.

After installation and restart dspMixFx_UR-C always shows “No device found”.

Cubase 11 AI doesn’t work as well.
If I plug in the UR22C into the Mac and starts Cubase 11 AI, it loads very long shows list of current drivers

  • Built-in Audio
  • Steinberg UR22C
  • Steinberg UR22C (High Precision)

and after selection Cubase is completely stuck.

The only way to close it - only force quit.

I have tried several times to uninstall and install this driver but it didn’t help.

Did you ever rebooted your Mac?
I know this is not usual on Mac but sometimes it could help…

Do the LED on the interface light up at all?

I have the same issue here.
The program starts in a few secs with built-in audio, but when I try to change driver to ur22c, it is completely stuck (spinning wheel).
It works well with Adobe Audition, so I am pretty sure the driver is doing its job.

Thanks if anyone can shed some light.

I just figured it out!

Still doesn’t work! Help please…