Ossia deleted, but MXL has an extra voice

I created a four-voice, grand staff score with an ossia staff in several places, then deleted all the ossia notes and all the ossia staffs. When I send my file via MXL to Musescore, there’s an extra voice, all rests. How can I eliminate that extra voice?

Here’s an example Dorico file. Export to MXL and notice the extra voice (a rest) in the upper staff.
ossia_extraVoice.dorico (628.1 KB)

For the time being there’s no way to prevent an ossia staff from being exported in MusicXML. Your best bet would be to create a new piano instrument held by a new player, copy and paste the music from the two visible staves to the new piano, then remove the old one, and re-export.

That worked beautifully, thank you!

I was using ossia to remind myself of musical options, then didn’t need them later. Ossia must be “latched on” somehow.