Ossia staff visibility

I’ve come across an issue where I can’t get a satisfactory result.

I am creating a piano reduction for the orchestra part of a concerto. There is a passage where I must include a smaller staff above the piano to show other instruments’ material (not playable by the pianist, but necessary to understand what’s going on).

If I create an ossia staff and include the notes there it looks perfect. The only problem is that “show ossia staves” also shows the soloist’s ossia staves, which I do not want in the piano reduction score.

It would be good to be able to show on a case by case basis the staves where ossias are visible. For example, only show any ossias from my piano staff, while hiding those from my soloist’s staff.

Either that or allow us to change the size of ANY staff. I tried adding an additional staff to the piano part, except I can’t get it to cue size without also affecting the actual piano part.

Is there a way to change the size of one staff, some selection somewhere I might have missed?

Does this work?

no, since Dorico considers the added staff as part of the piano player. therefore it changes the staff size of the entire piano.

I’ve tried adding a single staff “new player” and resizing it, which works, but I can’t get the nice dashed barlines I had from the ossia staff.

Ahhh ok, sorry about that.

If the appearance of the staves can be aligned with system breaks, you could add an additional Player and bracket it with the Piano. This Player could then have a reduced staff size.

this is what I’ve done:

added a new player, piano, made it a single staff, resized it.

looks great so far.

now the only thing missing is the dashed barlines between that extra staff and the piano grand staff.
Is there a way to make the barlines dashed?

I don’t believe so.

that’s a shame.

using the ossia function gives the nicest-looking result, except that there isn’t the flexibility of being able to show certain staves’ ossias and not others’.

if one could hide/show ossia staves on a per-staff or per-layout basis then the ossia function would be perfect.

1 Like

and I just came across another difficulty with using an option other than the ossia function:

Ossia staves have dashed barlines, AND they can stop mid-way through a system.
Using another staff doesn’t allow this.
Dorico adds an obligatory system break when I want to hide that extra staff, which pushes material off onto the next system, and so on down the line.

can I delete an ossia from one layout, but not from another?

if I could simply delete the ossia from the piano reduction, but NOT from the actual solo part, then I’d be set, I could simply use an ossia in that piano reduction without having to see the one from the soloist’s part (while the soloist’s actual part would retain its ossia staff)

I tried scaling the Soloist Ossia to 1% (0% isn’t possible) but, that left an artifact.

I know it’s dreaded but, your best bet may be to have a duplicate Soloist Player for the Piano reduction. But, that of course would require duplicating the music.

1 Like

I think having a duplicate soloist staff might work. it’s not like it needs to show elsewhere.

However, there’s a LOT of formatting in it, with stem directions and special articulations (it’s a viola solo part). Is there a way of copying all of that to the new part?

Not sure how this will work but, I would temporarily add both Soloist Players to the Layout.
Position the second right below the first.
Select all the music in the original Player (sans ossias).
Use Edit > Paste Special > Duplicate to Staff Below

That hopefully will do it.

thank-you, I will try that tomorrow (right now my brain has gone numb trying to get the correct results in my score).

sadly, this doesn’t work.
the solo part has lots of layer work, to differentiate different strings, up stem, down stem, etc…) and the “duplicate to staff below” doesn’t seem to catch all of that. it makes a big mishmash of single-layered music that’s impossible to read.

is there a way of copying that will preserve selected layers? right now, “duplicate to staff below” is simply cramming everything into upstem layer 1.

Ah, sorry to hear that. I’m afraid I’m out of suggestions.

Do you mean everything is in one voice? That happens too with alt-click. I find that the old copy-paste does the job correctly, so that could be an option.

if I just select everything in a bar and try to ctrl-copy it into the other staff, it mooshes everything into a single layer, and ignores some triplets (thus making one bar of music often stretch out over multiple beats past the bar I’m trying to copy)

paste-special does the exact same thing.

this appears to be one function where Finale has the upper hand. it copies exactly when you select material to copy.

I will shortly take an image of what I’m trying to copy, maybe that will help in seeing the issue.

the up-stem notes are voice 1 up-stem, the down-stem notes are voice 1 down-stem.

the triplet markings for all the down-stem notes have been hidden.

rests have been removed.