OT Sine Player does not appear in Dorico 3

Hi,

I downloaded the new OT player along with a free library called Layers.
The installation placed the .vst in /Library/Audio/Plug-ins/VST and I also copied it into VST2.
I also included “Sine Player” vst2whitelist.txt (along with VSL’s Synchron Piano Player).
The Synchron Piano Player is present in Dorico’s VST list; Sine Player is not.

Any ideas?

Thank you,

Alex

PS Logic Pro & Cubase can use SINE Player. Logic Pro uses OT’s provided AU but I am not sure whether Cubase uses the AU or a VST that Dorico cannot.

Please do Help > Create Diagnostics Report, which silently creates a zip file on your desktop. Please attach it here, thanks.

Here it is, Ulf!

Alex
Dorico Diagnostics.zip (1.09 MB)

Hi Alex, in the same way as Synchron Pianos, you have to put “SINE Player” on the whitelist for VST2 plug-ins. Then it will work.

Hi Ulf,

As I wrote in my original post - ‘I also included “SINE Player” vst2whitelist.txt (along with VSL’s Synchron Piano Player).’

Specifically …
Why does a VST2 from VSL work and a VST2 from OT does not?
Furthermore, why does Cubase recognize the OT/VST2?

I also rebooted my mini several times for good measure; no luck!

Many thanks,


Alex

From the diagnostics you posted I can see that Sine Player does get detected by Dorico but refused, because it is not on the whitelist. The diagnostics also contain your whitelist and from that I can see that only Synchron Piano is on that list. So if you edit that once more it shall work. And make sure that you save the whitelist before closing the editor window.

I had a closer look at the diagnostics file myself, where vst2whitelist.txt is included, and found the solution.
The Dorico diagnostics collection facility indicated where it expects to find vst2whitelist.txt. And it’s not where I’d expect to put it.
BTW, I cannot explain how Synchron Player Piano ended up in the right place.
The right place turns out to be /Users/username/Library/Preferences/VSTAudioEngine3/vst2whitelist.txt".
SINE Player worked when added to it.

According to this URL (Dorico 1):
https://helpcenter.steinberg.de/hc/en-us/articles/206899770-How-to-use-VST2-plug-ins-in-Dorico
vst2whitelist.txt should be installed in “/Users/username/Library/Preferences/VSTAudioEngine”

According to this URL (Dorico 2):
https://steinberg.help/dorico/v2/en/dorico/topics/play_mode/play_mode_vst_instruments_whitelisting_t.html
vst2whitelist.txt should be installed in “/Users/username/Library/Preferences/VSTAudioEngine2”

What about Dorico 3 then?
I could not find any Dorico/Steinberg documentation that it’s “/Users/username/Library/Preferences/VSTAudioEngine3/vst2whitelist.txt in.”

I do not know how VST vendors populate /Library/Audio/Plug-ins/VST, /Library/Audio/Plug-ins/VST2 and /Library/Audio/Plug-ins/VST3. But it I would expect that a VST2 would not appear in /Library/Audio/Plug-ins/VST3. vst2whitelist.txt is about VST2s, hence I’ed expect it to reside in /Users/username/Library/Preferences/VSTAudioEngine2/, and maybe /Users/username/Library/Preferences/VSTAudioEngine.
Conflating the VST generation with Dorico’s version, as it seems to be the case here, is confusing. At least to me …

Alex

In order to take away the location confusion, in Dorico 3, in the Preferences dialog under the Play tab we added a button that brings up an editor window with the pertinent whitelist. So just add the name of the VST2 plug-in there, save and you are done.

As to the locations of VST2 plug-ins. Well, the VST2 specification was not strict about the locations of VST2 plug-ins. They can be virtually anywhere, you just have to tell then the hosting app (Dorico) where to find them. VST3 specification corrected that and only allows VST3 plug-ins to reside in specific locations, so the hosting apps know where to pick them up.

Thank you for the clarification Ulf!

And yes, I just discovered the Edit VST2 Whitelist in Preferences.

Alex

I have the same problem. Would you please summarize what to do to fix it? I am using Dorico 3.5.

Hi Peterandu,
simply go to the Dorico Preferences dialog and choose the VST Plug-ins tab.
Scroll down a bit and you see a list of blocked plug-ins. Highlight the SINE Player and below press the “<” button, then it will move over to the list of allowed plug-ins.
Apply and close the dialog, restart Dorico andSINE Player shall turn up.

Hi, Thank you. It does not work for me. I can see SINE in the whitelist there.

My solution: upgrade both Dorico and SINE to the newest version, and it works now for me.

Thank you for the reply.

Good to hear that you sorted it yourself.

I’m getting some really strange things happening when I try moving the ‘Blocked Plug-ins’ from the ‘Block Plug-ins’ list to the ‘Allowed Plug-ins’ list. After I click ‘Apply’ exit and come back, the plug-ins are not only in allowed but also in blocked!

Also, I firmly believe there’s a bug because everytime I move them from allowed to blocked or back they get duplicated.

So, now my plug-ins are showing in both lists and SINE Player is STILL not available when I go to try to add it as a VST instrument on the ‘Play’ tab.

I’ve got the latest versions of both Dorico (3.5.12.1066) and SINE Player (1.0.5.589).

Ok, I just discovered the ‘Clean Audio Engine Cache’ button which I believe fixed my problem. After completely closing out of Dorico and restarting (which took longer due to Dorico rescanning plugins), SINE Player now shows up!

Ok, now that I’ve got SINE Player working with Dorico I have a different problem. The “soft outs” as OT calls them are labeled ‘1/2’, ‘3/4’, all the way up to ‘31/32’. In SINE Player the only option I see is to assign the instruments to a MIDI channel (under where it reads ‘Articulation List’. In the ‘Mixer’ tab it shows you which soft outs each instrument is assigned to, and it correctly shows the names of the instruments, but back in the Dorico mixer, they show up only with the ‘soft out’ numbers. In my case I’ve got Cello (1/2), Bass (3/4), and Harp (5/6). The really weird thing is that the instrument names show up under ‘17/18’ (cello), ‘19/20’ (bass) and ‘21/22’ (harp), but the faders for those don’t work or show any signal coming through. The signal only comes thru and the fader controls on 1/2, 3/4, and 5/6, but no name of instruments!

Any ideas as to what I may be doing wrong?

1 Like