Ottava line question

There’s no default setting to get automatically get rid of the line that follows a short ottava indication when using dots, is there? Modifying the End X Offset makes it go away, but my client wants them to look like second and third examples here, not the first, and well, there are a lot of them. Before making manual changes or Alt-clicking I just wanted to confirm there’s no setting I’m overlooking. Thanks!

No. At some point I managed to fiddle until it was just a little blob, but it was a bit of a workaround, and not totally gone.

He doesn’t actually want them completely gone, he just wants the line gone and to show a few dots like the others here which I edited. It’s not that big of a deal, there’s about 70 pages of piano music. I’m just lazy and don’t want to spend a half hour fixing them only to realize they could have been modified globally in 5 seconds, LOL!

Todd, I don’t find that I end up with a solid line when using a dotted line for octave lines, even if the duration of the line is short. Can you attach a minimal project that reproduces the problem?

Would it be possible to have an option to get rid of the hook? I remember I had this need once, and was unable to fulfill it.

Sure, sample file attached. Just in case it looks different on your end, here’s an image of what I see:

The first 3 on each staff show the line and are unedited. The fourth is edited and only shows the dots. Thanks for looking into it! (456 KB)