Output chain in channel editor wrong after save

This Bug has been present since 8.02 I believe. Only worked correctly for a short time:

The problem can be demonstrated for multi-timbral VSTs instantiated as either rack or track instruments. It is just described here using a rack instrument as an example.

  1. Create a new project
  2. Add an instance of HALion Sonic SE to the rack & enable output ‘HSSE Out 2’
  3. Create two midi tracks (‘MIDI 01’ & ‘MIDI 02’)
  4. Connect track one to HS channel 1
  5. Connect track two to HS channel 2 and set output selector in the inspector to ‘HSSE Out 2’
  6. With focus on track two, open the channel editor and make sure ‘Show Output Chain’ is enabled. It will show the chain as ‘MIDI 02’->‘HSSE Out 2’ (As expected)
  7. Save the project, exit, and re-open it
  8. Repeat step 6. Although the Inspector still shows the output selector as ‘HSSE Out 2’, the channel editor now shows it as ‘MIDI 02’->‘HSSE Main’

Image attached for reference of the issue
Cubase Channel Settings Bug.jpg

I have the same issue. I’m still on Pro 8.5 though, but was curious if 9 solved this.

A quick up/down scroll on the output in the inspector to change it to another output and then back again resets the channel editor to the correct state. This is obviously not ideal and is very annoying in larger projects.

Hi nsharpstudios

I am copying a reply to another post in to this reply because I think it is completely related. I hope it is of help:


If it is of any interest, there have also been audio routing options disappearing from tracks when they are imported.

Please see ‘Group Audio Routing Problems’ in the issues forum.

Sternberg have been made aware and are currently working on a fix for the issue, but the one you mention sounds similar to it, so it may be worth getting in touch with them as it may be something they could implement as part of the fix.

The person I have been in contact with is Oscar, so maybe ask for him as he knows about this problem. I can also reply to his email and mention that you will be in contact of you like?

Hi Robby 12, I have gotten a “We are aware of this issue” since it broke in Cubase 8… I have no hopes of this ever being taken care of.

This is the response from 2013 on this issue:


I have confirmed the issue. Do you also have a forum post with other users having the same problem? If so please send me the link.

Thank you
Jeff Deno
Steinberg Support

This Bug remains in 9.0.3. Just tested it.

Still not fixed in 9.5 - Shame bell ringing.

When I saw the upgrade this was one of my first thoughts. Such a pity.

Still going to upgrade though, it looks very good.

They should just remove the “Show Output Chain” option in the midi instruments if they can’t fix it. It’s too confusing seeing the wrong channels.