output routing not in order

Hey everyone

This is a very small problem, but may be important to people with OCD like myself…

Does anyone know why the output routing options are out of order when connecting to VE Pro (i.e. Midi in 1, 10, … 16, 2, etc. see screenshot)
Does anyone know how to reorganize them in ascending order or is this some kind of bug?

I’ve seen this on other computers so I know it’s not just me with this problem…

Thanks!
Dylan
Screen Shot 2016-05-30 at 6.19.41 PM.png

It is in order! It’s just that it’s sorting alphabetically, not numerically. I think you can do something about it, though. In Device Setup, go to MIDI Port Setup, where you can edit the entries in the ‘Show As’ column. You need to make sure that all numbers are 2-digit. Change 1,2,3, etc to 01,02,03, etc and you should be fine.

Btw, I would also find this annoying and I don’t have OCD (or at least I don’t think so…) :wink:

PS: This is also why many people, me included, write dates backwards (YYYY-MM-DD), especially in filenames, to preserve the sort order.

Ah, makes total sense, thanks!
Does make me feel better that there is a reason for it, although I am unable to change it in Midi Port Setup.
The output options in question don’t show up in the setup window (see attached).
Any other ideas?
Screen Shot 2016-05-31 at 2.28.18 PM.png

D’oh! What was I thinking? :unamused:
But you get the idea. I’m sure you can do this, though, for in/output devices. Try the ‘ASIO DirectX Full Duplex Setup’ app. Should be in your menus somewhere, if not try ‘C:\Program Files\Steinberg\Asio’.

Hmm lost me a bit there

Don’t believe I have that app…
and I’m also on a Mac so couldn’t find that directory, or one like it
The ASIO Driver I am running is a PreSonus FireStudio if that has any merit

Not familiar with Macs, I’m afraid. Have you got nothing that allows you to set up the ASIO? I must confess, it’s been so long since I’ve needed to go anywhere near this stuff, I’m very rusty on it. I’m about out on ideas too but remain convinced that you can change this somewhere. Perhaps you should start a new thread (new, to save my blushes!) with a title specific to renaming the port names, now that we’ve managed to move things on a bit. Have you looked around here? You can’t be the first person to try this.

Did you ever figure this out? I also would like to know how to fix this issue.