Overlapping Midi Part Recordings lost -help!

I have been using Cubase since Atari days. I always use “Replace” mode when recording midi tracks. Previously I have been able to drop into existing parts and record beyond - freely - Cubase retaining all new data as a new part which you could glue if required.
With V6.04 I find that having punched in on a track (using L. locator) and continuing recording overlapping the exisiting track’s end, the new material is not kept when stopping transport (You can see the data on the track while you are recording, but it disappears when stopping).
Is this a bug or have I not set something up correctly (which is new to V.6)?

Hi,
In the lower left of the transport panel, you can select the MIDI record mode. Replace, Mix, Stack, etc. Hopefully, one of these will function the way you want it to. Perhaps the selection you had there was reset with the update install?
HTH
Sincerely,
J.L.

I had this same issue recently in the middle of a session with a client! It’s strange behavior for sure. Possibly a bug?

I definitely think this can’t be “normal”.
Can someone try the following and report back.

On a part recording (in “Replace” mode)

  1. Record midi part from Bar 1-4
  2. Set Left Loc to Bar 2
  3. Record Bar 2- Bar 6
    [Cubase creates a new part (Bar2-6) but the first 2 bars data is placed in the original part; the new data appearing at Bar 4-6
  4. Set Left Loc to Bar 4
  5. Record to Bar 8
    Cubase has now put all the new data in a part Bar 4-8
  6. Set left Loc to Bar 7
  7. Record to Bar 9
    Although you can see the graphic forming on the part as you record, when you stop the data beyond the (original) Bar 8 disappears

Inconsistent behaviour.
I have tried a “workround” by creating a large part covering all the bars I am likely to use, but after the initial recording the part is reduced to where I stopped and then we are back to the scenario above.
This surely has to be a “bug”. I have been working this way in Cubase for 20 years.

The workround that does seem to work is after every recording you use the Glue tube to create a single part, then punch in again. This is extremely tedious!

Are all you folk just using Audio these days or have you experienced the same problem?

Hi,
I don’t usually use “Replace” mode for MIDI, but, trying it now, I confirm your findings (except that, for me, it is consistent… it always keeps the new recording only till the end of the original part).
Here’s a little variant on your recipe, which makes me think this might well be a bug (please try it yourself, to confirm)…

  1. Do your first MIDI recording (say, eight bars long, starting at bar #1)
  2. Split the new MIDI Part at, say, bar #5
  3. In Replace mode, set Left Locator to bar #2, and drop in. Record till later than those initial eight bars.
  4. Stop
    Here, the new recording is kept only till the end of the first Part! (the Part after the split has gone!)

As far as I can tell, it has been like this since Cubase 6.0.0.

I tried your “recipe” and the part post Bar 5 was overwritten. But it didn’t disappear. I had to do another punch in at Bar 8 - Bar12, then all material beyond Bar 8 disappeared.
It is frustrating that after two punch ins on the same (extending) part at different points, Cubase doesn’t keep what you’ve just recorded - which could be your “eureka” performance!

Will this get picked up by the moderators and put in the Bugbase?

There must be something else at play here, then… the behavior is consistent here.

Just to verify…
when you did the 1st overdub, did you record until past bar #8?

Discovered one more thing… this works o.k. only if dropping in on a Part that begins at the very start of the Project.

Can the moderator’s agree with this and put it on the “bug” database. I find it extremely annoying and slowing down my work rate.

Cubase 6 does not keep overlapping midi recordings when in “Replace” mode!! Why has this changed from Cubase 5?

In Cubase 5 I used to record freely on a track, if I made a mistake I used to set the locator back a couple of bars and drop in and carry on til I had finished the part recording . Cubase 5 kept all replaced parts.
Cubase 6 shows the new “drop in” recording as a graphic but in most cases it disappears when you stop recording.
Scenario:
Record in “Replace” mode say from Bar 1 to Bar 4.
Then “drop-in” at L. locator at bar 3 and continue past Bar 4 to say Bar 6
New recording is kept - good!
Now set L. locator to bar 5 and record to say Bar 8 - You will see the graphic as you record but when you stop the new recording is kept only to teh end of the previous recording i.e. to Bar 6. Bars 7-8 are lost!!
Surely I can’t be the only user to record in this way?
Could someone try this and confirm my problem.
I am using Cubase 6.06 Build 362 64 Bit - but all Cub 6 versions have had this problem

All I want to do is to freely record a midi part without keeping/merging multiole versions.

I’m not getting that wrong behavior here :confused:. (tried in Cubase 6.0.6, and in 6.5.1). Following your recipe, the only thing that surprised me was that, after the last of those recordings, the previous overlapping Part got glued automatically to the original Part (so we see only one overlap), but the recorded material is correct (i.e. data replaced at the appropriate drop-in points).
You could try trashing Cubase Preferences (making sure you don’t have any Preferences folders from earlier versions present, so that Cubase will build new ones from scratch, rather than simply re-importing them when you next launch).

Do the parts that “disappear” move to new lanes? Are these parts only visible if you show lanes for the track in question?

I have made the test simpler!
Please try this - especially on Windows 7 PC’s - I have tried it on my laptop(32bit) and Main(64bit) with identical results.
I don’t use lanes, I have the midi recording set to REPLACE.
Step 1: Set Locators to (L) Bar 3 and ®Bar 5
Record some midi note data on a part - either manually or using the Locator drop-in/out mode.
You now have a part 2 bars long.
Step 2: Set Locators to(L)Bar 4 and ®Bar 8
Record some (overlapping/replacement) Midi data.
Watch the display part graphic as you record.
When recording stops the data has been replaced from Bar 4 up to Bar 5 (initial recording end) but disappears after Bar 5. i.e What you saw being recorded up to Bar 8 is no longer present!

Annoying!!
If you do this test please make sure you are not in Cycle mode and have the Midi Record Mode set to REPLACE.
Also please start recording somewhere after Bar 1 (If you record from Bar 1 it sometimes works correctly! but for one further recording only!)
I’ d be very interested in your results. Many thanks

Are you certain that you are running v 6.0.6? That’s an old bug, when not recording from the beginning. It was already fixed in v6.0.5. (like I said before, try trashing Preferences)

Vic
I “Defaulted” the Preferences and then opened a new project and tried the “recipe”. No problem this time - so I guess I’ll have to start again and set up a new set of preferences - boring!
I assume whatever was causing this unkept recording issue is something hidden deep in Preferences and cannot be altered?

I am about to reload everything onto SSDrives- having upgraded Kontakt and bought a second SSD.
Also got Groove Agent 3 pumping out Midi data working on 64 bit via JBridge.

Things are looking up!! Many thanks for replies.

If there are stuff like presets, key commands, etc. that you’d rather not trash, those are in fact safe. Just move your Prefs folder out of the way, let Cubase build new ones, then you can put those folders back again. (The main file that needs to be rebuilt is Defaults.xml… sometimes it is sufficient to trash only that one file.)