Overlapping staves in full score

The spacing is good on the second (and subsequent) page, but on the first page, Dorico is wanting to squeeze four systems on the page. How can I change the settings to make sure that overlap doesn’t happen? I’m guessing I could take care of it with a manual system break, but I’m wondering if there’s some setting that can just automatically fix it? Thanks!

There’s no manual Make Into Frame? Turn signposts on and check.

If not, can you attach project?

1 Like

If you are asking if I did something with frames in engrave mode, no I didn’t. I very rarely do anything with frames. I’m afraid I can’t share the project at this point.

All I’ve done so far is in layout options I changed to Tabloid and I changed the staff size to the smallest setting.

If I may, I think ypu’ve sent the least interesting view (it could have come from print mode…)
To be helped, it’s way more helpful to post a picture from Engrave mode (with all the great percentages markings) and with signposts visible. My 2 c.
In your case, it probably wouldn’t have changed much, but it would have avoided questions about breaks…

1 Like

I understand. I can’t really show the music, but I figured a wide shot would easily get me an answer if it was simply a setting in layout options that needed to be changed.

I understand. Note you can take a wide shot in Engrave mode, it will still be way more interesting to help you! Because if nothing turns red and no breaks are visible, we have a more precise idea of your spacing settings.

Right on. The piece isn’t that precious. It’s just not done enough for me to feel good sharing it. But in any case, here is the engrave mode pic. I see the red box at the bottom sayin git’s at 106%.

1 Like

Have you tried resetting layout options and seeing what happens?

Resetting fits like two measures to a page and puts it on A4 paper with a rastral size of 3. I need Tabloid and Rastral size 8.

I guess you could narrow it down using the Library Manager. Gradually reset the different layout options one by one, leaving out the ones you want to keep such as what you’ve described.

Just a thought…

The only layout settings I am changing is page size to Tabloid and Rastral size from 3 to 8.

We can see in the engrave mode that the page is 106% full. Isn’t there some setting somewhere to make it so it’ll never be more than x% full?

You could help Dorico by adding a frame break where you think it’s wiser.
Unfortunately, Dorico does its casting off by considering a number of parameters but not all of what’s on the page. Since it’s a real-time operation (and not a process launched by the user as in TEX operations, where several typesetting processes might be necessary to render properly a document), there are some times where manual intervention is compulsory.

1 Like

Right, ok. Just making sure manual frame breaks is the solution here vs some sore of setting in layout options.

1 Like

You could try and increase the inter system gap in Layout options > Vertical spacing, but not sure about side-effects later in the piece. Those are essential settings you want to master when doing large jobs in Dorico :wink:

So it’s strange to me that we have an option for inter-system gap, but clearly Dorico is ignoring that preference on this page. This feels like a bug to me?

Could be. Or you could have some sorts of markings that are not taken into consideration for real-time casting off, but that takes vertical space in a way you end up with a 106% fill… Maybe @dspreadbury could chime in to give you more precise description of what’s happening there (on a Saturday, with its very busy schedule…) or you could experiment with manual breaks to get your work done :wink:

Yes, I will certainly do manual casting tomorrow when I have to get this done. In the meantime, I’m happy to be looking at this so we can collectively continue to improve Dorico.

This kind of thing often comes up. I’ve written many times about why it happens, so please excuse me for linking to one of my previous explanations:

The short story is that Dorico has to make an estimate while it is spacing about which systems will fit in the frame. During spacing and casting-off it can then transpire that its estimate was wrong (because items on adjacent staves end up needing more space than the initial estimate suggested; Dorico can’t know which items on adjacent staves will actually need to be moved apart vertically until the rhythmic spacing is determined). By the time it becomes clear the estimate is wrong, Dorico has already decided which bars and systems will be in the frame, and the result is that the systems end up too close together.

For what it’s worth, I think rastral size 8 is too small. Have you been informed by your professors that you simply must use that rastral size and get three systems to a page? Since the music in your piece is reasonably busy, with complex divisions of strings, I would suggest that a larger rastral size and two systems per page would make your score easier to work with for the conductor.

4 Likes

Thanks Daniel. I agree on the Rastral size. I will read that other thread.