Overview of removing collisions in a finished part/layout?

I’m finishing up my first score in Dorico and not quite at this stage yet but trying to think ahead - once everything in the music is final, what’s the best plan of attack for removing the various types of collisions in the different layouts I’ll need? I imagine some of this must be done in layout options, engraving options, some manual tweaking in various ways, but rather than just dive in and start trying stuff and risk making it worse I figured I’d ask first!

So for example, the clarinet part comes out like this at the moment (ignore all the text notes to myself)

There isn’t an “update layout”/“redraw screen”-type command in Dorico is there?

No, it updates automatically. Dorico does a great job of avoiding collisions, so there’s something wrong with your layout!

Your text comments are causing all sorts of spacing issues, methinks.

Also, do you have frame breaks set to display?

The best course of action is to leave it alone until the end. Next, spend some time in Layout Options—Vertical Spacing. Ideal Gaps and such.

If you can post it here, I’ll take a look. If you want.

Whoah! That’s pretty extreme! You may find that simply removing the textual “notes to self” fixes many of the problems. Beyond that, Layout Options > Vertical Spacing is full of stuff that’s likely relevant. I suggest you at least temporarily increase the gap between systems there.

And no, there isn’t a “recalculate” button - Dorico calculates dynamically, based on rules. It also compensates when you manually adjust things in Engrave mode. Where this causes you problems, check the properties panel for the “Avoid collisions” property - turning it off prevents Dorico from automatically compensating for what you’re adjusting.

edit: fools seldom differ and all that…

That’s a relief! Thanks both. I’ll work on getting the text notes out of there and see how it looks at that point.

Having a similar issue. I’ve tried altering the “flow heading top margin” but this does nothing to alleviate the problem.
How can I make space between the flow title and the start of the music?

You can increase the space below the flow title (pull down the lower margin and add a blank text line with a space in it under the actual token line), but that will affect all flow headings unless you create separate flow Master Pages.

Thanks, Derrek. That worked! I had been increasing the “flow header top margin” like a big dummy.

If you want to increase the space below the flow heading, you want the flow heading bottom margin not the top one.

The flow heading top margin changes the flow heading position if it is in the middle of a page between two flows.

You might also consider using the Comments feature for your “notes to self”. That won’t mess up the page layout.