Owned Dorico 20 minutes, nothing is working

I use Sibelius First, and was happy to see the sale on Dorico, so I got the full version. I put my license key on a USB licenser and have installed Dorico on two Macs: One 2012 Mac mini with 10.14, one 2012 Mac Pro with 10.11.

Issue #1: It is sluggish. It’s eating 40% of the CPU when sitting idle, and there’s a 100ms latency between clicking and selection, which makes it feel like my Mac is struggling to run it.

Issue #2: It cannot do playback. On my Mac Pro, I tap the P key, and the playback bar moves across the staff but no sound comes out. On my Mac mini, when I press play, literally the sound comes out a full measure past where it’s written. Video at https://twitter.com/avidrissman/status/1090815486672146432 .

I surely must be doing something wrong. I want my scores to look nice, sure, but the core functionality of making sounds correlating to the notes I put in is a really basic feature.

Thank you for any help.

Avi

This might help. Work through it systematically and if you hit a problem you can’t solve, you will then have a more specific question to ask than “help - nothing works”. https://www.youtube.com/watch?v=5BcPJd92zqU

One of the Steinberg audio guys reads this forum regularly, so you should soon get up and running.

Do you have any MIDI keyboards or controllers connected? We’ve seen reports of controllers that generate thousands of messages cause system slow-downs. Try disconnecting any devices temporarily to see if that’s the cause. There was another user earlier in the week who had a slow system due to (I think) a misbehaving USB hub.

Alas, no keyboards or controllers involved.

My USB is keyboard, mouse, webcam, elicenser, U2F key.

Thank you for the video link; watching now.

Mac Pro: No audio. Edit > Device Setup… > Device Control Panel… showed the output being set to “Built-in Digital Output”. Switching that to “Built-in Output” fixes sound not happening. There is no weird delay as on the Mac mini.

When I go home tonight I’ll watch that video again for the mini.

Re the CPU use, I opened the Activity Monitor, and Dorico doesn’t take up any CPU while idle, but the VST Audio Engine idles at 40% CPU. Oh VST…

It might be a dumb question, but: do you actually have something connected to the optical output?
Also, what’s your playback device?

It might be better if you create a Diagnostic Report (via Help menu) and post it…

I have nothing connected to the optical out. I use a headphones set with mic, which I attached to a CTIA splitter and plug into the front of my Mac Pro. I do cleanup and retypesetting for a SATB group, so no fancy playback devices for me.

In any case, things are working well enough on playback on my Mac Pro. Tonight I will poke at my mini.

Just a wild guess (and I’m not a Mac user) - try disconnecting the webcam. I assume it’s got some audio capability, and that might be getting mixed up with the VST audio somehow - or Dorico thinks the webcam is a video you want to play alongside your score, for some weird reason.

Obviously there should be a combination of settings that work, but the first task is to isolate what’s causing the VST to eat 40% CPU (it should be more like 4% or even less).

This video - one of many produced by the Steinberg team, all well worth working through - suggests solutions to a range of problems with playback.

…literally the sound comes out a full measure past where it’s written…

would seem to suggest your two phenomena are connected.

Mac #1 has the webcam, had the VST Audio Engine at 40% CPU, and playback works great. Mac #2 has no webcam, has the VST Audio Engine at about 17%, and has the sound coming out a measure late.

Am investigating based on that video.

Is your sound card sample rate set to 44.1K? That is usually one reason the playback cursor and sound do not align.

Mac #2:

  • Opened the HALion Sonic SE window; the piano at the bottom of the window is very responsive and audible.
  • Fiddled with the audio output; it was at 48k and setting it to 44.1k caused Dorico to just hang on attempting playback. Whoops, let’s put that back.
  • Trashed ~/Library/Preferences/VSTAudioEngine2; yay! It works.

Thank you. Sorry for the crankiness.

Re the CPU hogging… shrug? That’s why I have CPUs.

The sluggishness is still bothering me. I hope it gets better.

The sluggishness and the 40% (or even 17%) CPU may be connected. You shouldn’t be getting noticeable sluggishness with score that is only 2 or 3 pages long, but it won’t magically get better on its own.

But as I said before, I’m not a Mac user so I don’t have any ideas how to fix that.

40% CPU usage during idle is pretty high for the audio engine. At what buffer size are you running the audio interface. Try to increase it and see if by that the CPU usage decreases.

For reference, on my system with a buffer of 2048, VST engine uses c. 9%-12% CPU, even while playing back 16 instruments. So it’s definitely an issue at your end, rather than expected behaviour.

More experimentation, back on Mac #1.

First, I just figured out that Dorico selects notes on mouse-up, not on mouse-down. Oooooooooh, that explains a lot of the sluggishness I was perceiving.

Second, adjusting the buffer size (Edit > Device Setup…?) causes no change.

I can help investigate if you want, and can send you an Activity Monitor sample. I can’t read it as the VSTAudioEngine2 isn’t shipped with symbols.

Yeah, we don’t ship our software with symbols – very few (if any) commercial software vendors do. But certainly if you want to sample the VSTEngine2 process and send it to Ulf, he’ll be able to take a look and see what it’s up to.

I also ship commercial software, so my comment about VSTEngine2 not being symbolicated was not intended as a critique. Sorry if it came across that way.

I’ll send Ulf the sample.

So it does. I’ve been using Dorico since the first release, and I never noticed that until you mentioned it!