Oxygen49 not seen by Cubase (solved!)

Hello everyone, help me solve this puzzle please:

I recently bought a M-audio Oxygen49, hooked it up (with USB)
Installed it automatically withouty a cd-rom (as suggested)
Booted Cubase and there it appeared as, I believe,a generic USB audio device in the inspector where you can choose your midi IO.

All is well, had a ton of fun.

Then all of a sudden, I probably did something that causes Cubase to not recognize it anymore. :frowning:
Pressing keys, moving knobs sliders etc etc on the Oxygen49 doesn’t lit up the midi in bar on the transport panel.

So my actions so far:

Reconnect the oxygen with different (usb) cables and to different usb ports.

Removed the Oxygen via configuration panel, rebooted PC and installed it again.

Trashed Cubase preferences.

Reset Midi ports within Cubase via devices.

Removed a USB hub (which was on another USB port then the Oxygen anyway)

Disconnected all other USB devices I use (Novation, external harddrive, Line6 PODxt) , removed the oxygen via configurations, rebooted computer without an internet connection and reinstalled the Oxygen49.

Still no result.

When I am in windows configurations, it let’s me know that the M-audio Oxygen49 is connected, installed and working properly.
So it’s there, it’s connected, the knobs are working cause I see different values in the Oxygen49 display, the computer recognizes it, it said that after installing it that the new hardware is installed and ready for use.

But Cubase doesn’t see it.

I am out of ideas, and I think it is something really simple.

Please help.


I went further trying things, and thought what did I change the last 24 hours?

Well I installed my Logitech webcam and skype because a friend of mine is on holiday for two months to Bali.
Any way, long story short, I removed all logitech software and skype from Configurations> Add Remove Software
and what do you know.


It works again, I strongly suspect that the logtech drivers are the cullpritt btw, I mean evey time I use logitech software (mouse, keyboard, I also have a harmony remote) it constantly is making adjustments, going on internet doing all sorts of thinfgs I do not understand (and don’t want to)