Padshop 2 and Logic Pro

Hi folks, first time post so go easy.

I am failing miserably to get Logic Pro X (LPX) to recognise and see Padshop 2 and make it available to use as an instrument.

  1. I have a macbook pro, (OS 10.14.6), LPX is 10.15.1. Steinberg’s e-licenser is at I bought Absolute 3 a while ago and at some point I also got Padshop, as I remember later upgrading to Padshop Pro, which worked just fine with LPX.

  2. I recently paid £25 to crossgrade from Padshop Pro to Padshop 2. After installing it, Padshop stopped being visible in the drop down VST instrument menu in LPX. The e-licenser also started playing up and refused to recognise the crossgrade activation code for Padshop 2 saying something about there being no valid Padshop licence or some such. Hmm, rat smell. OK, I thought, maybe I downloaded Padshop as part of the Steinberg download asst as a trial perhaps? In all honesty I couldn’t recall. I went to my Steinberg user account and sure enough, no sign of Padshop registered to me, no emails I could find with any Padshop activation code. Why then could I use Padshop in LPX? Although I have seen a few issues reported on forums about Padshop Pro and Padshop 2 causing issues, they seemed to be few and far between, so I put it down to operator-error. :open_mouth: OK, the solution must be to buy the full Padshop 2 package from scratch, albeit a somewhat embarrassing way forward, clearly all my own fault etc. :unamused:

  3. Padshop 2, full package paid for, downloaded, installed, activated and registered just fine in the e-licenser (USB).

  4. In LPX, the plugin manager sees “Padshop” (version 2.0.10), not Padshop 2.

  5. I have been round several houses trying to uninstall Padshop 2, first using the Steinberg download or app helper (epic fail -Padshop still visible in LPX plugin manager), then carefully uninstalling component parts of Padshop from all over my Mac - yes it then disappeared from LPX plugin manager. I have re-set LPX prefs. I have deleted the AU cache about 0.5m times, re-booted the mac the same no of times.

Apart from offering up my first born as a blood sacrifice, I have run out of ideas. Spoke to Apple who said they agreed, yes I had done everything they would have suggested, while waiting for Steinberg support to respond at glacial speed only to say, have you tried deleting the AU Cache and speaking to Apple? I had already told them I had deleted the AU Cache…

I throw myself on this great and humble community…


1 Like

I’m having the identical problem. Did you ever get this resolved? The only validated solution(?) I found involved setting up a separate partition and user, and installing LXP there. Not a pretty picture if that’s the only way forward. Quick update would be appreciated, as I’m (literally) feeling your pain.