Padshop 2 and Retrologue 2 not working in FL Studio

I am facing issues with Padshop 2 and Retrologue 2 not working in FL Studio.

System:
Windows 10 Pro, latest build.
FL Studio 20.7.3 (also tried in 20.8 RC4, but still the same issue - which possibly indicates it is not an FL Studio issue, I reported to Image-Line as well though).
Latest version of the plugins (also tried with previous versions)
Latest e-licenser control center software with maintenance successfully finished and licenses registered fine.

Problems:
Both these plugins (VST2 and VST3) crash inside FL Studio when loading or changing presets. When plugins crash, the GUI becomes completely non-functional. Rarely, FL Studio crashes/shuts down.

Occasionally the plugins will not load itself and FL Studio will given an error “failed to load the plugin”.

Steps to reproduce the problem:

  1. Install the plugins
  2. Open FL Studio and run a full scan with verify. Sometimes the plugins get missed in the scan, so might need to repeat until you see both scanned successfully.
  3. Open an instance. Can be VST2 or VST3. Sometimes, the plugin will fail to load altogether, especially when there was a scan problem.
  4. Try to change presets by using previous/next buttons or by opening the browser window and selecting from there.
  5. Keep repeating step #4 and you will see the crashlogs I have posted above. The plugin will become non-functional.

Step 4 is where the problem happens, i.e. when changing presets.

Crash logs attached for reference.
Crash logs_Padshop 2 and Retrologue 2.zip (1.82 KB)
Kindly resolve this problem at the earliest. The plugins are not usable at all.

Thank you.

Anyone, please?

Hi LoveEnigma,
I’m not able to reproduce it here (Win 10, FL Studio v20.7.3 build 1987, Padshop 2.0.20, Retrologue 2.2.30.233).
Do you use a USB elicenser? Have you tried another USB port already? To me it sounds like a copy-protection issue.
best regards
Gerrit Junge

Hi Gerrit,

Thanks for your reply.

I figured out that it was indeed an issue with the soft e-licenser, yet again! For some reason it was not betting synced/updated after maintenance.

I reinstall e-licenser control center, got new soft e-licenser in place (using the Steinberg troubleshooter available to fix the creation issue) and got new activation codes for everything.

Now everything is working fine. Strangely though, Halion Sonic SE 3, did not have the problem before doing all this, which might be something to do with it being free.

Thanks for your help. But to be honest, the soft e-licenser system is really frustrating and it has wasted a lot of time on two occasions. I don’t know why things get messed up after few days of using the plugins and once updates to plugins or e-licenser control center are installed, the problems reappear at some point.

Hello LoveEnigma,
I´ve been having this issue more than one year, frustrating period for me… Padshop and Retrologue have absolutely the same symptoms as you had (in Windows 10 too), nothing has helped so far, even offical support couldn´t help. Padshop2 and Retrologue are unusable for me. I came to the conclusion that it must be something hardware-related. So you´re saying that reinstalling e-licenser is the only thing you did and this helped?
Thanks

Hi Ivan1981,

I feel you. The problem is with soft e-licenser, which is the most frustrating copy protection I have ever used.

If you go to C\ProgramData\Syncrosoft, you will probably see that the soft e-licenser date modified is old, which I think means it could be out of date and maintenance is not helping too.

I would suggest deleting that soft e-licenser (move to thrash just in case).

Then, install the latest e-licenser software.

Follow this article to create a new soft e-licenser at the same location.

Launch e-licenser software and copy the serial number of the e-licenser. Go to Steinberg account online and under my products select any one product for reactivation. Simply input the new soft e-licenser number and you will get new activation codes for everything.

Activate the codes in the e-licenser software on your PC/MAC and register them to that soft e-licenser number.

Run maintenance to ensure everything is synced fine.

Now the plugins should work fine.

Hope it helps. But honestly, a terrible licensing system!!!

Thank you. This looks promising, I will definitly try, though strange that Steinberg does knot know about this issue in e-licenser (if this it the reason, of course…)

You know what? IT FUCKING WORKS!!! :joy: Man, you are a genius! After almost one year you helped me to solve this! Please go and teach Steinberg support guys! They really need to change the licenser… God bless you , LoveEnigma!

Thank you!

I´m going to get drunk now…

1 Like

Glad to know that it worked for you. Thank you so much for your good wishes. I reciprocate the same to you, Ivan1981. :pray:

Haha, enjoy! Let Padshop and Retrologue enjoy as well. :grinning: