Padshop 2 does not appear, but I can play the default sound

Hello, this is my first time here. I have Cubase 10.5 as my DAW and my operating system is Windows 10. When I try to open up Padshop 2 the window does not appear, but I can play the default Padshop sound when you open it up. This is strange because I use to open it up before, but now I can’t seem to do it.

What happens is that the “Edit Instrument” button is highlighted in blue, but nothing appears. This only happens with Padshop, because I can open Retrologue with no problem. I check to see if the Padshop window is minimized but it isn’t. I was wondering if anyone has a clue on fixing this issue?

Hi and welcome on the forum,

Do you use HiDPI screen, please?

Please, make sure, you Padshop plug-in is up to date.

Hello Martin

My screen is an LCD. I have a laptop it is an Asus ROG G751JL.

I haven’t tried updating Padshop how do you go about doing that?


Download the latest update from the Steinberg Download Assistant, please.


I went to the Steinberg Download Assistant, and I found out that Padshop needed to be updated. So I did. After the update, I tried opening Padshop on an empty project. The Window still doesn’t appear. I tried doing it in other projects, but there was only one project where I managed to open Padshop. Everywhere else, the window doesn’t appear, but I can play the default sound.


Do you have an idea, what is different in the project, where you can open it, please?

Do you see the plug-in header, or no plug-in window at all? Do you see the plug-in window listed in the Window menu?

Hello, I tried figuring out the difference between that project and my new one, but I can’t seem to find a difference. I don’t see the plug-in header or a plug-in window at all. But I will say this. In that project where I can open Padshop, there are two instances of Padshop. One instance I can open, but the other I can’t. I’ve attached screenshots of the two instances if that helps.

This is the instance where I can’t open Padshop, in that very same project.


To me it looks like the window is hidden somewhere. Click Windows > Window, select the plug-in window and click Reset Layout. Does it help?


I’ve tried doing Window > Windows, select Padshop, and clicked Reset Layout, and still nothing. I’ve tried the rest of the buttons there but it doesn’t seem to work either. I’ve also tried doing it in other projects, and nothing.


Is this the only screen you have available, please?

Can you see the plug-in window, when you mouse hover over the Cubase icon in the Start bar, please?

Yes, it’s the only screen available. I hover my mouse over the Cubase icon in the start menu and the project is the only window available. I click on the minimize button on the upper right of the window of the project and the only thing that is under it is the Cubase Pro window and that’s it.

Thanks again for taking a special interest in my problem. I appreciate it.


That’s interesting, you saw the window in the Windows menu, but not in when you hover over the Cubase icon in the Start bar.

Yeah, it’s very strange. And inconvenient, because I use Padshop quite often in my projects, but now I can’t use it anymore. Do you think if I somehow uninstalled Cubase and install it again it might fix the issue or no? (Ideally, I wouldn’t want to do it because it took me more than a week to get Cubase to work in my system)


You can try to reinstall Cubase, but I would expect, this would fix it. I would more expect, trashing preferences could do this.

Could you try in the Cubase Safe Start Mode [Disable preferences], please?