PadShop Pro - Logic Pro X on Mavericks (10.0.7)

After installing PadShop Pro, I get the following error from Logic Pro X Audio Unit Manager.

My key is plugged in since my Cubase Elements 7 has no issue on Mavericks and the license is on the same key as PadShop Pro.

validating Audio Unit Padshop by Steinberg:

AU Validation Tool
Version: 1.6.1a1
Copyright 2003-2013, Apple Inc. All Rights Reserved.
Specify -h (-help) for command options


VALIDATING AUDIO UNIT: ‘aumu’ - ‘pads’ - ‘Stbg’

Manufacturer String: Steinberg
AudioUnit Name: Padshop
Component Version: 1.1.0 (0x10100)
Component’s Bundle Version: 1.1.0

    • PASS

TESTING OPEN TIMES:
COLD:
Time to open AudioUnit: 28.667 ms
WARM:
Time to open AudioUnit: 0.135 ms
FIRST TIME:
FATAL ERROR: Initialize: result: -1


validation result: couldn’t be opened

Just to clarify, I took a look at your registered account. Your Padshop license is not on the same USB key as your Cubase Elements 7 license (I’m guessing your CE7 license is on your SeL since it isn’t registered).

I would suggest installing the latest eLCC http://www.elicenser.net/en/latest_downloads.html and running the Maintenance. Does Padshop load in CE7 properly?

Also, to verify, did you do the AU update for Padshop at the bottom of this page?
http://www.steinberg.net/index.php?id=downloads_padshop&L=1

I installed this on my MacMini and this worked, but on my MacBook Pro this didn’t work.
So I tired the “repair permissions” on my MacBook Pro then reinstalled PadShop Pro and everything is fine.


One last gripe which has to do with locking out a user when they accidently put in the wrong password.
This can happen since I have several accounts at other sites and I keep forgetting which password I use.

Let me mention why locking out is a bad thing.
If I write a program to capture all the usernames from the posts that get posted here and then use those usernames to login but use garbage on the password, I’ve just locked people out of there logins.

Is that the desired affected, to have hackers lock people out of your system.

Let me keep trying passwords until I finally click on the “resend password”. That’s the whole purpose of having a “resend password”. Don’t lock me out.

I have an issue with the AU version/Logic Pro X as well (OS X Mavericks 10.9.2, macbook pro , Logic X, 16GB RAM):

It makes the default sound, and if i move my hardware mod wheel it’s being reflected in the Padshop GUI.
But if you want to move a fader or knob you have to go halfway up to the left in the GUI to move that fader/knob. And it seems not really by the same amount. And it only works within the constraints of the Padshop GUI. So I can’t access many functions even if I tried.

Do you have any plans to fix this? Got a feeling the issues persist, that you’re not overly eager to do anything about it, seems the AU issues are still pretty much the same. I hope I’m wrong.

Are you using a Retina display? I would suggest opening Logix in Low Resolution (go to Applications, select Logic and press Command-i to open Get Info, then check the option to “Open in Low Resolution”). Do you have the same issue then?