padshop pro - wrong max os version error

Hello. I am running mac yosemite 10.10.5 I have just downloaded padshop pro to run with cubase 8.5. When I open the installer it says “wrong mac version - you need at least mac os X 10.5.0 to install this software.”
I read there were some compatibility issues, but now they say that is should be compatible. Please help. What do I do?
Padshop (Pro) 1.1.20 Compatible

Thanks.
compatible.jpg

Hey ghaggard, I’ve just figured it out (took me a while :). Padshop and PadShop Pro are the same Plugin. Only the Licence makes it to Pro. Just download the Padshop Pro license to your eLicenser by entering the license key in eLicenser Control Centre. Then restart the plugin, should be updated to Pro. Cheers!