Page Numbering

I have made some kind of error when numbering pages?

I typed in %p but some pages I have duplicate Page numbers?

  1. How do I remove all Page Numbers to start afresh?


  1. How do I correct the error?

Many thanks

How very strange! (I have no idea what could be causing that, I’m afraid. Are you using any Page Number Offset, in Score Settings>Project>Notation Style?).
So, to be clear, are you saying that, somewhere along your score, a page gets the same number as the previous page? And is the page numbering offset accordingly from that point onwards?
Does the score contain multiple Parts on a same track? (try gluing them together, see if that makes any difference)
Try deleting, then re-typing the Page Text event that contains the Page Number variable. (maybe save a new version after deleting but before re-typing, then reload the project?)

Thanks vic,

The Page numbers are ’ greyed ’ and I see no way to Delete them?

The Page numbers are missing on 1 & 2, but 3 onwards they are ’ doubled up? ’


3 4 5 6 7 8 9 etc.
3 4 5 6 7 8 9


Tried to send file privately to you but it says *.cpr is not allowed?

Can you provide an email I could send it as an attachment?

Any chance of a screenshot? The only way they’d be “greyed out” is if you have filtered either the Layout Layer or Project Layer (the orange or green button in the Score Editor’s extended Toolbar)… which would explain why you can’t delete them.
How did you create them in the first place? The recommended way would be to insert a Page Text event (either in the Project layer or the Layout layer) on the first page, which opens a special dialog, where you can enter the desired text (in this case, the %p variable) and set the position…e.g. top right, and e.g. “show on all pages”. In that case, you can’t delete them individually (although you can Hide them), but to delete them all, you simply select one of them, delete it and it will delete them all (because they are all “one event” in this instance).

Not quite sure what you mean by “doubled up”
EDIT… Aha! :bulb: I think I can guess what you’ve done :wink: (could be completely up the wrong tree though :wink: )…
Did you enter the page numbers, not as I described above (i.e. Page Text), but individually (i.e. a separate event for each page), as Layout Text? You would indeed see “doubling up” if your score layout is made up of two staves, and in Score Settings>Layout, the “L” column is checkmarked for all staves… uncheck all but the one for the top staff.
But I’d certainly recommend you get rid of them all, then do as I suggested earlier (Page Text) :wink:.

Eureka!, I figured it out in large part thanks to your Layer comment!

I used the ’ Layer Tool ’ (P & L) to highlight the greyed out Page Numbers, then I deleted the redundant ones.

All done nicely!

Many thanks!