Page size bugs

2 problems:

DEFAULT LAYOUT PAGE SIZE - I cannot get Dorico to default to US Letter for all parts and score when creating new projects or importing music xml

DEFAULT PRINTER PAGE SIZE - In print mode: Dorico will default to the 1st paper size in the selected printers available paper sizes. Every time. I can select all layouts, set to 8 1/2 x 11. Fine. Then if I go to setup and add another player I must again change paper size in layout options, and again change paper size in print mode for this part. It will remember paper size for a specific part in the current project. New project or new player defaults back to A3.

STEP 1 - I create a new project and add a string section.

If I select any part in the left (players) pane, then click the layout options button (in right pane), the default page size is Letter.
If I select a single layout in right (layouts) pane, then click the layout options button, the full score default is Letter, individual parts are all A4.
I can select all layouts in layout pane and change the page size for all.
Add another player - default is A4.

If I select any layout in the left pane, the paper size is A3, first in the list of available printers.
Change printers, the default size is changed to that printer’s first available size.

add another player
repeat above steps.

I’ve wasted a few precious hours on this. What am I missing?

Dorico v
macOS 10.12.6

Default layout page size:
To save as default, read these instructions carefully. Notice the part about selecting ‘Part’.

Default printer page size:
In his next reply in the same thread, Daniel explains this behavior. In case your not aware - you can set print size for several parts simultaneously by cmd- or shift- clicking them in the left hand panel.

Seems to me that if your OS default is set to letter, this will be reflected in the ‘Print’ dialog found in the bottom left corner of print mode.

Andgle, thanks tons for taking time to help me sort this out. But I’m not there yet. Workarounds, yes. Fixed, sadly, no.

What I’ve figured out is:

  • when I follow the steps outlined in Daniel’s post I can indeed set default paper sizes for scores, but scores only.
  • in Layout Options, new parts always default to A4
  • in Print Mode, new parts and scores always default to A3 in the page setup on the right. (always the first paper size in the selected printer’s list)
  • in my OS preferences, region is set properly to U.S. as is default paper set to US Letter
  • in Page Setup and Print… on the left bottom pane in Print mode, the pages are properly set to US Letter, but the print preview reflects the printer selected in the right pane.

What I must do is:

  • upon creating a new score, after adding parts, go into layout options, select all parts and choose “Letter”
  • before printing, select all layout and select 8 1/2 x 11

This is OK for the short term, but I hope this is recognized as a bug and is on the list of things to fix someday. I understand there are priorities, etc… U.S. users don’t want special treatment, yet this seems like an unusual thing to spend hours trying to sort out. And there will be that day a few months from now when in a rush before a rehearsal I must add a player to an existing score, go to print, printer is screaming something at me about paper sized not found, I’m threatening to pummel the machine with a ball-peen hammer and a light-bulb goes off in my head " aaaaa the d@mn page settings in dorico!"

Is there a “reset *every setting known to Dorico and modern man to factory defaults” button someplace? Maybe I’ve buggered it up somehow.

I read the thread that Dorico can’t see inside the mind of the local print dialog or printer drivers or whatnot … but this only happens for me with Dorico. A puzzle. The best longterm solution might be to lobby for the U.S. to adopt European paper sizes along with the metric system and driving on the wrong side of the road. :smiley:

Follow the instructions in this post carefully; they work!

In the forthcoming update you will be able to set your default page size for new projects to US paper sizes in Preferences in a “set and forget” fashion.

You should find, though, that your printer’s default paper size is already chosen when you switch to Print mode, so I’d be interested to find out more about why it’s choosing an ISO size rather than Letter size. What kind of printer do you have?

It’s a networked printer on our office windows network - konica minolta bizhup C258.

OK, I did the instructions above again. Somehow it’s working now! I won’t worry about the default printer - very excited for coming update. You guys are amazing. Keep yourselves healthy, the community needs you.

Our network printers are setup to receive department codes and user passwords - this has caused no end of problems for the mac users in our office just getting things to print occasionally. I wonder if these konica printer drivers for iOS can be causing the problem?

“Bizhup” – what a funny word. We don’t have one of these printers on hand, alas, but if this continues to be a big problem for you we can look into buying one to test if it’s not prohibitively expensive.

:smiley: I think it is “bizhub” possibly referring to business hub?

Anyway… it’s Friday, and that’s the extent of my guesses!

I don’t know if this is related, but… I’m using US letter size for the layout setup. When I go to the print menu (using a local Brother printer), that PAGE SETUP always defaults to A4. Easy enough to change. BUT… if I change printers (say, to a networked Ricoh), the PAGE SETUP size changes to 12"x18". I can change that to 11"x17" as needed. If I change BACK to my local Brother printer, the PAGE SETUP size reverts back to A4 (not the previous letter size I had changed it to).

  • If I use a second Ricoh printer installation defined for 11"x17" paper (which I had to use for Sibelius booklet printing), the PAGE SETUP reflected is 12"x18".

  • If I use a third Ricoh printer installation defined for legal 11"x14" paper (again, for Sibelius booklet printing), the PAGE SETUP defaults to 12"x18".

  • If I switch back to my local Brother printer, the PAGE SETUP reverts to A4. Nothing that I do will make the page setup “stick” – I have to ALWAYS remember to check that size setting every time I print.

This happens with the parts too. Thoughts/comments/suggestions?