partial showing after render

Why after a rendering the spectral view shows only the start of the file It should be preferable scale adaptation size to show the entire file imho ?

There’s a preference that affects this.
File / Preferences / Audio Files / Editing / Display /
Next to Number of Seconds at the bottom of the Display section, select “Whole Audio File”.

Thanx !