(partly solved) Can't record Halion 6 in Cubase 9.5 (and various other problems)

Hello,

I recently installed Cubase Pro 9.5 and got myself a Halion 30-day trial to test out if I want to have it. Now, I watched the whole Groove3 Cubase 9 tutorial and wanted to try something out. I started an empty project, added a Halion instrument track and started recording. I hear the sound when I press keys on my MIDI keyboard, but nothing is created. I can’t draw a new track with a pencil tool, as well. And when I click on three dots on the transport bar, nothing gets expanded.

What the hell is going on, why is nothing working?

Regards,
kampfusbeke

P.S. After I went back to the Cubase window, MIDI input produced no sound and I couldn’t restart recording. Then I saved the project and after restarting it, there was indeed some MIDI data in the track. Soon after, Cubase crashed and asked me to save the project under a different name. Should I reinstall it? I installed the last update while installing 9.5.

(Oops, it got published after all). It seems that that problem is linked to Halion 6. Did anyone else have this problem?

When I record for Halion 6, nothing appears on the track and most elements of Cubase’ interface are non-responsive. However, if I run it again from the beginning, I hear the sound and if I save the project, I see the track data. But it’s impossible to work with it.

When I record Groove Agent or add a loop, I see the track data and can work with Cubase. But when I add Halion again, the issue reappears.

After reinstalling Cubase and Halion those crash notification didn’t appear again, but everything is still the same. Sometimes, when I add Halion, it doesn’t even appear left of the track.

P.S. Another issue I have - from many different ASIO drivers only Generic Low-Latency ASIO driver works for me, but not all the time. Sometimes it isn’t producing any sound from the beginning and sometimes it stops. FL Studio ASIO driver works in Maschine for me and ASIO4ALL in FL Studio (but FL Studio ASIO driver stopped working there), they all don’t work in Cubase, though. Also, the generic one steals the focus of audio, so I’m unable to watch tutorials with Cubase started.

What OS are you using? Is it fully up to date? Are you using a very old eLicenser?

Windows 10, up to date, Cubase and Halion as well. The eLicencer ist from a Cubase 9 box, which was brand new.

OK, one more try today. First of all, ASIO4ALL worked after being selected for the second time. Still steals the focus of sound, but at least there’s working volume control in the Windows Mixer. After opening Cubase each time there’s usually no sound, no matter what ASIO driver is selected.

I added and recorded with Halion, at first no visible track data, but there was a rectangle. I opened Key editor and noticed, that the first note (pressed before the final pre-click) wasn’t recorded. I copied another note and created a couple more and there there was a crash again. After restarting Cubase there was track-data (bars). After working with them in Key Editor there was another crash, but after it I still was able to arrange the 8-bar recording in 32-bar progression and play it.

How do I make the note I play before the final pre-click start at the beginning of the first bar? Also, Cubase added a bar before the beginning and after I moved it, I couldn’t put it back like it was. I believe, it was empty.

After that I closed Cubase.

P.S. What I forgot to mention - after I create the first instrument track and record, there’s nothing in the lower zone, but I can open Key Editor. When I reopen the file, there’s MIDI data in the lower zone.

After a suggestion of a support guy I reinstalled Halion 6 for all users and renamed Cubase user folder to create a new one automatically. Same behavior. Then .10 update and deleted the new Cubase user folder. Same behavior, after I reload a file with Halion, I see MIDI data, but if I record more, I still can’t see new data. User interface partly loses function, like loop dividers, editing instruments toolbar or three dots in the transport toolbar. But no more crash-dump messages.

Yesterday a friend of mine wanted to look at the new Cubase and added Halion Sonic 3. Instead of recording, he created a couple of patterns, got a load of those crash-dump messages and then finally a real Cubase crash happend (Windows had to stop it).

Am I really the only one having those problems? Could the antivirus software be at fault? I have Kaspersky Internet Security.

OK, even though I now see the futility in posting on this forum, maybe someone else will learn from my post.

First of all, the support guy told me that the reason for those crashes was the graphics DLL. And after recent Windows and nVidia updates I started Cubase today and guess what - I see the track being recorded now and can change the editing tools after recording.

I also found out that there is a checkbox to give up sound focus when Cubase (or Halion standalone) is in the background. Actually, it’s directly under the ASIO driver list-box and I wonder, how I didn’t see it before or why no one told me it’s there (since, the futility of writing here).

However:

  • first of all, maybe I’m getting crazy or forget something, but I firmly believe that the Hexagon patch was sounding way richer before and now also sounds out of sync (both in Cubase and in FL Studio).

  • secondly, I still have to switch ASIO drivers back and forth to get sound in Cubase and, no matter what I do, I can’t get the sound to work in Halion standalone. I believe, I tried it before and it worked, no idea, why it isn’t working now.

This is usually an extremely helpful forum so I reckon you’ve got a problem that no one has come a cross before so they are unable to help you,
I wouldn’t let this stop you from asking for help in the future…

Today I made a first track in Cubase with Groove Agent and Halion. Everything went fine, but I found one more bug in Cubase. If “Release Driver if Application is in Background” is checked and I move focus to another program while exporting (at least, with FLAC), silence appears in the track at the percentage where focus is changed.

I think its because the trial version, no problems here with the full version of Halion6

Whereas I’m a new member, a former Sonar user and haven’t posted much here… I’ve read a lot and searched topics as I’m getting to know CB 9.5 pro…and I’ve seen a lot of good helps posted and problems solved.

I also wouldn’t let this one issue sour me inn being part of the group/posting.