"Paste special > Explode" creates beams across bars

First things first: This is from an XML-imported file that originated in Finale (v25.5).

When I select these two bars

and click on “Past special > Explode”, I get this result.

Across this file this has happened quite often to me, that’s why I’m bringing it up. The problem is reproducible where it happens (so if I undo the change, select again, and explode again, it will yield the same result), but it doesn’t happen everywhere (well, of course not…)
When I explode the notes one bar at a time, everything is correct.

I guess it’s more of a Finale-export-issue than a Dorico-import-issue, but I wonder if there might be anything I can to to prevent this in the first place?
If need be, I can send the file that exposes this behaviour.

Thanks for listening, Estigy

There are options in the XML-Import settings to not import custom beams. There are also options to reset the current beaming to Dorico’s default: Resetting beam grouping

I guess going from there, explode should behave normally again.

Hi, klafkid!

Yes, resetting custom beams did the trick! :beers:

But now I’m a bit confused: To keep the custom beaming (which I don’t want to, I’m just playing devil’s advocat here) I would have to reset custom beams, explode, and then reapply all the custom beaming? Because if I apply explode on each bar individually it works and custom beaming is kept as-is. Only if I apply the explode command to both of the bars at once, the beaming breaks.