Paste Special Swap

Hi

I’m fairly new to Dorico, so excuse what might be a daft question…
I’ve been typesetting a classical guitar duet. As is common with guitar music, I’ve selected “Allow Noteheads to overlap” in Notation Options in Write, so that I can notate an arpeggio over a sustained bass note with least clutter on the page.

I wanted to swap two sections of music between players and was delighted (that really was the word!) to find “Paste Special Swap” which is a REALLY neat function.
I drew round my music to select all the notes, copied, pasted and watched it make a terrible mess.

A bit of experimentation showed that drawing round overlapped noteheads only selected the upper voice.

My workaround was to disable notehead overlap, draw round the music, copy, paste special and then allow noteheads to overlap.

But am I missing something?

No, you’re not missing anything. This is a bit of a quirk in the way Dorico’s selection works: if you can’t select it, you can’t copy it. And Dorico doesn’t superimpose these notes on top of each other so that they’re both there: it omits one of the notes entirely so it cannot be selected and hence cannot be copied. This is something we’d like to change in a future version.

What helped me: you can select the beam, if it has one. Selecting the beam should also selects the note. If you want you can then deselect other notes with cmd/ctrl.

Thank you both - your time spent replying is much appreciated :slight_smile:

Hi
If you are copying (swaping) completed bars, that is easy using the system track.

Hi rafaelv
Thanks - I’ll try that out later!