Pasting Changes Rhythms?

I’m trying to duplicate an existing part (if you are curious why here is the thread where I got this suggestion: https://www.steinberg.net/forums/viewtopic.php?f=246&t=181066&e=1&view=unread#unread)

Pasting and using the option to duplicate the line to the staff below both results in the triplets in the original line being changed to duplets. I’m sure there’s a good reason for this, but I can’t seem to find a way to defeat it. I’ve attached a screenshot.

Any suggestions?

It’s because the tuplets are hidden, so when you select the notes, the tuplets are not selected as well. You need to turn on signposts to show the tuplet flags, and add those to the selection before you copy-paste.

Thank you so much!